# CVE-2026-69111: Milvus 2.6.22, 3.0.0 Unauthenticated Denial of Service via /management/stop

> Remote attackers can cause denial of service by sending unauthenticated requests to the management stop endpoint, requiring an upgrade to secure the service.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2026
- **Updated:** 6 Aug 2026
- **Also known as:** BIT-milvus-2026-69111, GHSA-fvg5-xr32-px64

## What is CVE-2026-69111?

CVE-2026-69111 is a high-severity missing authorization vulnerability in milvus-io milvus, published on 5 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Milvus through 2.6.22 and 3.0.0 contains an unauthenticated denial of service vulnerability that allows remote attackers to terminate service components by sending a crafted HTTP GET request to the management server on port 9091. Attackers can exploit the unprotected /management/stop endpoint, which bypasses REST API authentication middleware, by supplying a 'role' parameter to shut down the proxy, datanode, or querynode components, resulting in denial of service.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-69111?

1 open source package ship an affected version, including milvus.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `milvus` | Bitnami | All versions | 3.0.1 |

## How do I fix CVE-2026-69111?

Upgrade milvus to 3.0.1 or later.

## Is CVE-2026-69111 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69111 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69111 and fix it if it is affected.

What it is: CVE-2026-69111 is a high-severity missing authorization vulnerability in milvus-io milvus, published on 5 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69111 exists.

Affected packages and fixed versions:
- milvus (Bitnami): affected all versions; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69111/ (Markdown: https://insights.sbomify.com/CVE-2026-69111/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69111
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69111
- OSV: https://osv.dev/vulnerability/CVE-2026-69111

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69111/
Summaries are generated and may contain mistakes; the official description above is the record.
