# CVE-2026-69127: Kirby: System path exposure from error messages in the REST API

> Unauthenticated attackers can obtain full filesystem paths via unsanitized error messages in the Kirby CMS REST API.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2026
- **Updated:** 11 Aug 2026
- **Also known as:** GHSA-rf2p-vh74-7vvh

## What is CVE-2026-69127?

CVE-2026-69127 is a medium-severity vulnerability in getkirby kirby, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kirby is an open-source content management system. Prior to 4.9.5 and from 5.0.0 through 5.5.1, the REST API error handler can return unsanitized PHP error messages that expose the full filesystem path of the Kirby installation to unauthenticated API users. This vulnerability affects all Kirby sites that have not disabled the REST API with the 'api' => false option. This issue is fixed in versions 4.9.5 and 5.5.2.

Weakness: CWE-497 (Exposure of Sensitive System Information to an Unauthorized Control Sphere)

## Which versions are affected by CVE-2026-69127?

4 open source packages ship an affected version, including getkirby/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | All versions | 4.9.5 |
| `getkirby/cms` | Packagist | All versions | 4.9.5 |
| `getkirby/cms` | Packagist | From 5.0.0 | 5.5.2 |
| `getkirby/cms` | Packagist | From 5.0.0 | 5.5.2 |

## How do I fix CVE-2026-69127?

Upgrade getkirby/cms to a fixed version for your release line: 4.9.5 or 5.5.2.

## Is CVE-2026-69127 being exploited?

There is no known exploitation of CVE-2026-69127 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69127 and fix it if it is affected.

What it is: CVE-2026-69127 is a medium-severity vulnerability in getkirby kirby, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-69127 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected all versions; fixed in 4.9.5
- getkirby/cms (Packagist): affected all versions; fixed in 4.9.5
- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.5.2
- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69127/ (Markdown: https://insights.sbomify.com/CVE-2026-69127/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69127
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69127
- OSV: https://osv.dev/vulnerability/CVE-2026-69127

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69127/
Summaries are generated and may contain mistakes; the official description above is the record.
