# CVE-2026-69129: KubePi: Insufficient per-cluster authorization checks in cluster management APIs

> Authenticated users with cluster management rights can read or modify data in unauthorized clusters due to insufficient per-cluster access validation.

- **Severity:** Medium 5.8 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Aug 2026
- **Updated:** 27 Aug 2026
- **Also known as:** GHSA-cwg7-34p9-9hxh

## What is CVE-2026-69129?

CVE-2026-69129 is a medium-severity missing authorization vulnerability in 1Panel-dev KubePi, published on 26 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

KubePi is a Kubernetes multi-cluster management panel. In versions up to and including 2.0.0, cluster-scoped APIs do not consistently validate per-cluster access, allowing an authenticated user with cluster management permissions to operate on clusters outside the scope they were granted. Because the affected endpoints act on cluster-specific data without confirming that the requesting user is authorized for that particular cluster, a user assigned management rights over one cluster can, under certain role and cluster configurations, read or modify data in clusters they should not manage. This issue is fixed in version 2.0.1.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-69129?


## How do I fix CVE-2026-69129?

No fix has been published for CVE-2026-69129 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-69129 being exploited?

There is no known exploitation of CVE-2026-69129 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69129 and fix it if it is affected.

What it is: CVE-2026-69129 is a medium-severity missing authorization vulnerability in 1Panel-dev KubePi, published on 26 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-69129 in the wild and no public exploit code.

Affected product: 1Panel-dev KubePi. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69129/ (Markdown: https://insights.sbomify.com/CVE-2026-69129/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69129
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69129
- OSV: https://osv.dev/vulnerability/CVE-2026-69129

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69129/
Summaries are generated and may contain mistakes; the official description above is the record.
