# CVE-2026-69146: MLflow: LogInputs endpoint bypasses per-run UPDATE authorization in basic-auth

> Authenticated users can inject dataset inputs into other users' runs due to missing authorization checks in the LogInputs endpoint.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** BIT-mlflow-2026-69146, GHSA-3p64-6gvh-82v5, MINI-j6rc-4x44-q37w

## What is CVE-2026-69146?

CVE-2026-69146 is a medium-severity missing authorization vulnerability in mlflow, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MLflow is an open source AI engineering platform for agents, large language models, and machine learning models. From 3.13.0 until 3.15.0, LogInputs is absent from BEFORE_REQUEST_HANDLERS in the mlflow/server/auth package, allowing any authenticated user to call POST /api/2.0/mlflow/runs/log-inputs for another user's run_id and inject attacker-controlled DatasetInput records into the dataset_inputs lineage metadata without UPDATE permission. This issue is fixed in version 3.15.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-69146?

3 open source packages ship an affected version, including mlflow.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 3.15.0 |
| `mlflow` | npm | All versions | 3.15.0 |
| `mlflow` | npm | All versions | 3.15.0 |

## How do I fix CVE-2026-69146?

Upgrade mlflow to 3.15.0 or later.

## Is CVE-2026-69146 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69146 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69146 and fix it if it is affected.

What it is: CVE-2026-69146 is a medium-severity missing authorization vulnerability in mlflow, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69146 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 3.15.0
- mlflow (npm): affected all versions; fixed in 3.15.0
- mlflow (npm): affected all versions; fixed in 3.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69146/ (Markdown: https://insights.sbomify.com/CVE-2026-69146/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69146
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69146
- OSV: https://osv.dev/vulnerability/CVE-2026-69146

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69146/
Summaries are generated and may contain mistakes; the official description above is the record.
