# CVE-2026-69147: vLLM: Request-selected PyNvVideoCodec GPU decode bypasses static VRAM reservation

> Attackers can exhaust GPU memory by forcing specific video decoders, causing crashes in vLLM deployments with PyNvVideoCodec installed.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-8pw2-6jv3-mj5j, MINI-68cj-x2m2-v375, MINI-6cp8-3j5g-h76r, MINI-rv8r-8878-8rgw, PYSEC-2026-4178

## What is CVE-2026-69147?

CVE-2026-69147 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models. Prior to 0.28.0, request bodies for Chat Completions and Responses can set media_io_kwargs.video.video_backend to pynvvideocodec, and MediaConnector.fetch_video forwards that choice to VideoMediaIO even when startup configuration selected a software decoder. The engine's _reserve_mm_ipc_gpu_memory logic budgets decoder memory only from static configuration, so the request-selected VIDEO_LOADER_REGISTRY backend can create a CUDA context, decoder surfaces, and decoded-frame allocations that were not removed from the engine's KV-cache budget. An attacker able to submit video requests to a video-capable GPU deployment with PyNvVideoCodec installed can exhaust shared GPU memory, causing request failures, worker crashes, or denial of service. The first release containing the fix is version 0.28.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-69147?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.28.0 |
| `vllm` | PyPI | All versions | 0.28.0 |
| `vllm` | PyPI | All versions | 0.28.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-69147?

Upgrade vllm to 0.28.0 or later.

## Is CVE-2026-69147 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69147 exists.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69147 and fix it if it is affected.

What it is: CVE-2026-69147 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69147 exists.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.28.0
- vllm (PyPI): affected all versions; fixed in 0.28.0
- vllm (PyPI): affected all versions; fixed in 0.28.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69147/ (Markdown: https://insights.sbomify.com/CVE-2026-69147/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69147
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69147
- OSV: https://osv.dev/vulnerability/CVE-2026-69147

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69147/
Summaries are generated and may contain mistakes; the official description above is the record.
