# CVE-2026-69148: MLflow: CreateModelVersion source validation does not check READ permission on referenced run_id

> Authenticated users can bypass READ permission checks to access other users' model artifacts in MLflow.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** BIT-mlflow-2026-69148, GHSA-gqch-g4w5-7qcw, MINI-4cpq-jqj8-22pc

## What is CVE-2026-69148?

CVE-2026-69148 is a high-severity missing authorization vulnerability in mlflow, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MLflow is an open source AI engineering platform for agents, large language models, and machine learning models. Prior to 3.15.0, CreateModelVersion accepts a run_id or model_id after _validate_source_run() or _validate_source_model() in mlflow/server/handlers.py verifies only path containment, allowing authenticated users to create a model version that references another user's artifact directory and read files through GET /model-versions/get-artifact without the required READ permission. This issue is fixed in version 3.15.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-69148?

3 open source packages ship an affected version, including mlflow.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 3.15.0 |
| `mlflow` | npm | All versions | 3.15.0 |
| `mlflow` | npm | All versions | 3.15.0 |

## How do I fix CVE-2026-69148?

Upgrade mlflow to 3.15.0 or later.

## Is CVE-2026-69148 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69148 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69148 and fix it if it is affected.

What it is: CVE-2026-69148 is a high-severity missing authorization vulnerability in mlflow, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69148 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 3.15.0
- mlflow (npm): affected all versions; fixed in 3.15.0
- mlflow (npm): affected all versions; fixed in 3.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69148/ (Markdown: https://insights.sbomify.com/CVE-2026-69148/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69148
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69148
- OSV: https://osv.dev/vulnerability/CVE-2026-69148

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69148/
Summaries are generated and may contain mistakes; the official description above is the record.
