CVE-2026-69149 Angular SSR: Missing Fallback Raw-Content Serialization Escaping leads to Cross-Site Scripting (XSS)

High 8.6 Published Updated

An XSS vulnerability in Angular SSR allows attackers to execute arbitrary scripts via unescaped raw-content elements during server-side rendering.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-69149?

CVE-2026-69149 is a high-severity cross-site scripting vulnerability in @angular angular, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.27, 21.2.19, and 22.0.7, a Cross-Site Scripting (XSS) vulnerability exists in @angular/platform-server's DOM emulation dependency (domino) when serializing the content of fallback raw-content elements (<iframe>, <noembed>, <noframes>, and <noscript>). This issue is fixed in versions 20.3.27, 21.2.19, and 22.0.7.

Weakness: CWE-79

Which versions are affected by CVE-2026-69149?

8 open source packages ship an affected version, including @angular/platform-server. It affects 1 product.

PackageAffectedFixed in
@angular/platform-server npmAll versions to 19.2.25None
@angular/platform-server npmAll versions to 19.2.25None
@angular/platform-server npmFrom 20.0.0-next.020.3.27
@angular/platform-server npmFrom 20.0.0-next.020.3.27
@angular/platform-server npmFrom 21.0.0-next.021.2.19
@angular/platform-server npmFrom 21.0.0-next.021.2.19
2 more packages
@angular/platform-server npmFrom 22.0.0-next.022.0.7
@angular/platform-server npmFrom 22.0.0-next.022.0.7

Products include Angular Angular.

How do I fix CVE-2026-69149?

Upgrade @angular/platform-server to a fixed version for your release line: 20.3.27, 21.2.19 or 22.0.7.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-69149 being exploited?

There is no known exploitation of CVE-2026-69149 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-69149, GHSA-vpx6-8pjr-4g3v, UBUNTU-CVE-2026-69149.

Is CVE-2026-69149 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free