CVE-2026-69151 Angular i18n: Cross-Site Scripting (XSS) via event-handler attributes

High 7.6 Published Updated

Attackers can inject JavaScript via malicious translation files in Angular i18n pipelines, leading to cross-site scripting and potential code execution.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-69151?

CVE-2026-69151 is a high-severity cross-site scripting vulnerability in @angular angular, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.27, 21.2.19, and 22.0.1, the Angular compiler i18n pipeline permits i18n-onerror and other i18n-on event-handler attributes, allowing a lower-trust translation file to replace a static handler with executable JavaScript. This issue is fixed in versions 20.3.27, 21.2.19, and 22.0.1.

Weakness: CWE-79

Which versions are affected by CVE-2026-69151?

16 open source packages ship an affected version, including @angular/compiler and @angular/core. It affects 1 product.

PackageAffectedFixed in
@angular/compiler npmAll versions to 19.2.25None
@angular/compiler npmAll versions to 19.2.25None
@angular/compiler npmFrom 20.0.0-next.020.3.27
@angular/compiler npmFrom 20.0.0-next.020.3.27
@angular/compiler npmFrom 21.0.0-next.021.2.19
@angular/compiler npmFrom 21.0.0-next.021.2.19
10 more packages
@angular/compiler npmFrom 22.0.0-next.022.0.1
@angular/compiler npmFrom 22.0.0-next.022.0.1
@angular/core npmAll versions to 19.2.25None
@angular/core npmAll versions to 19.2.25None
@angular/core npmFrom 20.0.0-next.020.3.27
@angular/core npmFrom 20.0.0-next.020.3.27
@angular/core npmFrom 21.0.0-next.021.2.19
@angular/core npmFrom 21.0.0-next.021.2.19
@angular/core npmFrom 22.0.0-next.022.0.1
@angular/core npmFrom 22.0.0-next.022.0.1

Products include Angular Angular.

How do I fix CVE-2026-69151?

Upgrade @angular/compiler to a fixed version for your release line: 20.3.27, 21.2.19 or 22.0.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-69151 being exploited?

There is no known exploitation of CVE-2026-69151 in the wild and no public exploit code.

Sources

Also known as CLSA-2026-1786739230, CLSA-2026-1786741144, CLSA-2026-1786742832, CLSA-2026-1786743905, CLSA-2026-1786747673, CLSA-2026-1786793413 and 26 more.

Is CVE-2026-69151 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free