# CVE-2026-69151: Angular i18n: Cross-Site Scripting (XSS) via event-handler attributes

> Attackers can inject JavaScript via malicious translation files in Angular i18n pipelines, leading to cross-site scripting and potential code execution.

- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Aug 2026
- **Updated:** 3 Aug 2026
- **Also known as:** CLSA-2026-1786739230, CLSA-2026-1786741144, CLSA-2026-1786742832, CLSA-2026-1786743905, CLSA-2026-1786747673, CLSA-2026-1786793413, CLSA-2026-1786794014, CLSA-2026-1792161255, CLSA-2026-1792161258, CLSA-2026-1792163645, CLSA-2026-1792163649, CLSA-2026-1792208149, CLSA-2026-1792208150, CLSA-2026-1792250242, CLSA-2026-1792251563, CLSA-2026-1792281152, CLSA-2026-1792281155, CLSA-2026-1792325378, CLSA-2026-1792326074, CLSA-2026-1792345246, CLSA-2026-1792345651, CLSA-2026-1792366594, CLSA-2026-1792366929, CLSA-2026-1792375750, CLSA-2026-1792376121, CLSA-2026-1792380019, CLSA-2026-1792380022, CLSA-2026-1792382630, CLSA-2026-1792382631, DEBIAN-CVE-2026-69151, GHSA-jj27-h5hq-8x99, UBUNTU-CVE-2026-69151

## What is CVE-2026-69151?

CVE-2026-69151 is a high-severity cross-site scripting vulnerability in @angular angular, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.27, 21.2.19, and 22.0.1, the Angular compiler i18n pipeline permits i18n-onerror and other i18n-on event-handler attributes, allowing a lower-trust translation file to replace a static handler with executable JavaScript. This issue is fixed in versions 20.3.27, 21.2.19, and 22.0.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-69151?

16 open source packages ship an affected version, including @angular/compiler and @angular/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@angular/compiler` | npm | All versions to 19.2.25 | None |
| `@angular/compiler` | npm | All versions to 19.2.25 | None |
| `@angular/compiler` | npm | From 20.0.0-next.0 | 20.3.27 |
| `@angular/compiler` | npm | From 20.0.0-next.0 | 20.3.27 |
| `@angular/compiler` | npm | From 21.0.0-next.0 | 21.2.19 |
| `@angular/compiler` | npm | From 21.0.0-next.0 | 21.2.19 |
| `@angular/compiler` | npm | From 22.0.0-next.0 | 22.0.1 |
| `@angular/compiler` | npm | From 22.0.0-next.0 | 22.0.1 |
| `@angular/core` | npm | All versions to 19.2.25 | None |
| `@angular/core` | npm | All versions to 19.2.25 | None |
| `@angular/core` | npm | From 20.0.0-next.0 | 20.3.27 |
| `@angular/core` | npm | From 20.0.0-next.0 | 20.3.27 |
| `@angular/core` | npm | From 21.0.0-next.0 | 21.2.19 |
| `@angular/core` | npm | From 21.0.0-next.0 | 21.2.19 |
| `@angular/core` | npm | From 22.0.0-next.0 | 22.0.1 |
| `@angular/core` | npm | From 22.0.0-next.0 | 22.0.1 |

Products: Angular Angular.

## How do I fix CVE-2026-69151?

Upgrade @angular/compiler to a fixed version for your release line: 20.3.27, 21.2.19 or 22.0.1.

## Is CVE-2026-69151 being exploited?

There is no known exploitation of CVE-2026-69151 in the wild and no public exploit code.

## Other vulnerabilities in @angular angular

- [CVE-2026-68945](https://insights.sbomify.com/CVE-2026-68945/): Angular: Cache-Key Ambiguity in HttpTransferCache Leading to Cross-Request Response Reuse and State Poisoning (high 8.8)
- [CVE-2026-46417](https://insights.sbomify.com/CVE-2026-46417/): Angular: SSRF via Hostname Hijacking in @angular/platform-server (high 8.8)
- [CVE-2026-50168](https://insights.sbomify.com/CVE-2026-50168/): Angular: URL Parser Differential in @angular/platform-server leading to SSRF Allowlist Bypass (high 8.8)
- [CVE-2026-54266](https://insights.sbomify.com/CVE-2026-54266/): Angular: Weak 32-Bit Cache Key Hashing in `HttpTransferCache` Leading to Cross-Request Data Leakage and State Poisoning (high 8.8)
- [CVE-2026-41423](https://insights.sbomify.com/CVE-2026-41423/): Angular: SSRF via protocol-relative and backslash URLs in Angular Platform-Server (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69151 and fix it if it is affected.

What it is: CVE-2026-69151 is a high-severity cross-site scripting vulnerability in @angular angular, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-69151 in the wild and no public exploit code.

Affected packages and fixed versions:
- @angular/compiler (npm): affected all versions up to 19.2.25; no fix listed
- @angular/compiler (npm): affected all versions up to 19.2.25; no fix listed
- @angular/compiler (npm): affected from 20.0.0-next.0; fixed in 20.3.27
- @angular/compiler (npm): affected from 20.0.0-next.0; fixed in 20.3.27
- @angular/compiler (npm): affected from 21.0.0-next.0; fixed in 21.2.19
- @angular/compiler (npm): affected from 21.0.0-next.0; fixed in 21.2.19
- @angular/compiler (npm): affected from 22.0.0-next.0; fixed in 22.0.1
- @angular/compiler (npm): affected from 22.0.0-next.0; fixed in 22.0.1
- @angular/core (npm): affected all versions up to 19.2.25; no fix listed
- @angular/core (npm): affected all versions up to 19.2.25; no fix listed
- @angular/core (npm): affected from 20.0.0-next.0; fixed in 20.3.27
- @angular/core (npm): affected from 20.0.0-next.0; fixed in 20.3.27

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69151/ (Markdown: https://insights.sbomify.com/CVE-2026-69151/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69151
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69151
- OSV: https://osv.dev/vulnerability/CVE-2026-69151

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69151/
Summaries are generated and may contain mistakes; the official description above is the record.
