# CVE-2026-69153: PostCSS: incomplete fix of GHSA-6g55-p6wh-862q — attacker-controlled sourceMappingURL reads arbitrary .map files when `from` is unset

> An attacker can read arbitrary source map files via path traversal in PostCSS when the 'from' option is unset, exposing sensitive source content.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Aug 2026
- **Updated:** 3 Aug 2026
- **Also known as:** CLEANSTART-2026-PI70585, CLEANSTART-2026-SY59629, CLEANSTART-2026-WU05348, CLSA-2026-1790190219, CLSA-2026-1790200936, CLSA-2026-1790202643, CLSA-2026-1790412857, CLSA-2026-1791633097, CLSA-2026-1793111755, DEBIAN-CVE-2026-69153, ECHO-18e1-f116-f4cc, GHSA-fxqj-rqcc-2cmp, MINI-4cc9-6rhm-6c3j, MINI-87h2-rrqv-w6g7, MINI-g6c4-ghq5-2fjc, MINI-gm2q-2cr2-pjh9, MINI-hvp8-vxrv-7cmc, MINI-jmjg-hrxj-83gj, MINI-jqrp-f5vv-r5m6, MINI-mw7v-vx24-pmqp, MINI-pwj7-6v75-fp87, MINI-v5jv-4r5v-j94c, MINI-x8pr-hjvc-2xm8, RHSA-2026:50070, UBUNTU-CVE-2026-69153

## What is CVE-2026-69153?

CVE-2026-69153 is a medium-severity path traversal vulnerability in postcss, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PostCSS takes a CSS file and provides an API to analyze and modify its rules by transforming the rules into an Abstract Syntax Tree. Prior to 8.5.19, if from is unset, an attacker can cause PreviousMap.loadFile() to read an unintended source-map file by supplying an absolute or directory-traversal sourceMappingURL. The resulting map’s sources and sourcesContent may then be exposed to the application. This issue is fixed in version 8.5.19.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-69153?

2 open source packages ship an affected version, including postcss. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postcss` | npm | All versions | 8.5.23 |
| `postcss` | npm | All versions | 8.5.23 |
| `prometheus3.5` | Red Hat:hummingbird:1 | All versions | 0:3.5.5-0.7.hum1 |

Products: Postcss Postcss.

## How do I fix CVE-2026-69153?

Upgrade postcss to 8.5.23 or later.

## Is CVE-2026-69153 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69153 exists.

## Other vulnerabilities in postcss

- [CVE-2026-45623](https://insights.sbomify.com/CVE-2026-45623/): PostCSS: Arbitrary file read and information disclosure via attacker-controlled sourceMappingURL in CSS comments (high 7.5)
- [CVE-2023-44270](https://insights.sbomify.com/CVE-2023-44270/): PostCSS line return parsing error (medium 5.3)
- [CVE-2021-23382](https://insights.sbomify.com/CVE-2021-23382/): Regular Expression Denial of Service (ReDoS) (medium 5.3)
- [CVE-2021-23368](https://insights.sbomify.com/CVE-2021-23368/): Regular Expression Denial of Service (ReDoS) (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69153 and fix it if it is affected.

What it is: CVE-2026-69153 is a medium-severity path traversal vulnerability in postcss, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69153 exists.

Affected packages and fixed versions:
- postcss (npm): affected all versions; fixed in 8.5.23
- postcss (npm): affected all versions; fixed in 8.5.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69153/ (Markdown: https://insights.sbomify.com/CVE-2026-69153/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69153
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69153
- OSV: https://osv.dev/vulnerability/CVE-2026-69153

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69153/
Summaries are generated and may contain mistakes; the official description above is the record.
