# CVE-2026-69189: Hoppscotch: Cross-user private data exposure and UserHistory IDOR via team GraphQL resolvers

> Authenticated users can access and modify other workspace members' private data and history due to missing authorization checks in GraphQL resolvers.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-p25p-g9jp-7q46

## What is CVE-2026-69189?

CVE-2026-69189 is a high-severity missing authorization vulnerability in hoppscotch, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Hoppscotch is an open source API development ecosystem. Prior to 2026.6.0, the team, teamMembers.user, RESTHistory, GQLHistory, currentRESTSession, currentGQLSession, environments, globalEnvironments, and settings GraphQL paths expose another workspace member's private User data, while toggleHistoryStarStatus and removeRequestFromHistory in the UserHistory service accept another user's history identifier without enforcing userUid ownership, allowing an authenticated workspace member to read private request history, session data, request contents, authorization headers, environment values, and settings and to modify or delete the victim's private history entries. This issue is fixed in version 2026.6.0.

Weakness: CWE-862 (Missing Authorization), CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-69189?


## How do I fix CVE-2026-69189?

No fix has been published for CVE-2026-69189 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-69189 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69189 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69189 and fix it if it is affected.

What it is: CVE-2026-69189 is a high-severity missing authorization vulnerability in hoppscotch, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69189 exists.

Affected product: hoppscotch. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69189/ (Markdown: https://insights.sbomify.com/CVE-2026-69189/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69189
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69189
- OSV: https://osv.dev/vulnerability/CVE-2026-69189

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69189/
Summaries are generated and may contain mistakes; the official description above is the record.
