# CVE-2026-69198: ip-address: a CIDR suffix on the parsed address suppresses special-use classification and can bypass SSRF and trust-boundary checks

> Attackers can bypass SSRF protections by adding a CIDR suffix to IP addresses, causing the library to misclassify internal IPs as external.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Aug 2026
- **Updated:** 4 Aug 2026
- **Also known as:** CLEANSTART-2026-JM61604, CLEANSTART-2026-RO11754, CLSA-2026-1793097608, CLSA-2026-1793181094, DEBIAN-CVE-2026-69198, ECHO-0168-8a52-6156, GHSA-4xrf-jv44-h6hh, MINI-26g9-8xc8-hgxx, MINI-4j37-xm3r-2h67, MINI-4qjm-q34j-w82r, MINI-593h-555p-95m3, MINI-5c8x-p694-5m44, MINI-6h6r-wcp4-mp2x, MINI-6w6p-5rpx-m7gr, MINI-72j9-f57h-c99r, MINI-946m-2cm6-44c4, MINI-9q8x-h9x2-rh95, MINI-9wf3-4fwx-jvqr, MINI-c7j9-rfc2-fmrp, MINI-gg32-rcq9-h565, MINI-hw65-ch96-f9xj, MINI-hw6q-xchh-q3cp, MINI-mmqq-74jh-69g7, MINI-pqp5-pqg2-hr4h, MINI-qmmp-pc2c-76f5, MINI-r6pr-vfm2-v2gf, MINI-rghw-px9c-874m, MINI-wjp8-chm2-pfhq, UBUNTU-CVE-2026-69198

## What is CVE-2026-69198?

CVE-2026-69198 is a medium-severity server-side request forgery vulnerability in beaugunderson ip-address, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ip-address is a library for parsing and manipulating IPv4 and IPv6 addresses in JavaScript. From 10.1.1 until 10.2.2, every special-use classification method is built on isInSubnet, which short-circuits to false whenever the address's own subnet mask is shorter than the reference range's mask. That mask comes verbatim from the CIDR suffix on the parsed input, so appending a suffix such as /0 suppresses classification entirely: isLoopback(), isPrivate(), isLinkLocal(), isCGNAT(), isMulticast(), isUnspecified(), isBroadcast(), isULA(), and getType() all report an internal address as unremarkable, while correctForm() and address still return the real internal target. An application that builds a network trust-boundary decision on these checks, for example a filter intended to block Server-Side Request Forgery, or SSRF, may therefore treat an internal target as external and allow the request. The underlying bit comparison is correct, and mask(n) already returns the first n bits of the full parsed address independently of subnetMask; the defect is solely that the containment guard sits in the classification path. This issue is fixed in version 10.2.2.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-69198?

2 open source packages ship an affected version, including ip-address.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ip-address` | npm | From 10.1.1 | 10.2.2 |
| `ip-address` | npm | From 10.1.1 | 10.2.2 |

## How do I fix CVE-2026-69198?

Upgrade ip-address to 10.2.2 or later.

## Is CVE-2026-69198 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69198 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69198 and fix it if it is affected.

What it is: CVE-2026-69198 is a medium-severity server-side request forgery vulnerability in beaugunderson ip-address, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69198 exists.

Affected packages and fixed versions:
- ip-address (npm): affected from 10.1.1; fixed in 10.2.2
- ip-address (npm): affected from 10.1.1; fixed in 10.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69198/ (Markdown: https://insights.sbomify.com/CVE-2026-69198/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69198
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69198
- OSV: https://osv.dev/vulnerability/CVE-2026-69198

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69198/
Summaries are generated and may contain mistakes; the official description above is the record.
