CVE-2026-69205 Http4s: Ember Transfer-Encoding value parsing (TE.CL / TE.0 request smuggling)
Attackers can exploit request smuggling in Http4s Ember to bypass access controls, hijack requests, or poison caches due to incorrect header parsing.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-69205?
CVE-2026-69205 is a high-severity vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Http4s is a Scala interface for HTTP services. Prior to 0.23.35 and 1.0.0-M47, Ember’s HeaderP.parse uses a case-sensitive substring test for the Transfer-Encoding value and decodes header bytes with the platform default charset. Values such as Chunked are not recognized, values such as notchunked are incorrectly accepted, and Unicode case folding can turn a Kelvin-sign byte sequence into a match when UTF-8 is used. Intermediaries that apply RFC-compliant token and charset rules can therefore disagree with Ember’s Content-Length or zero-length framing, enabling TE.CL or TE.0 request smuggling, access-control bypass, cross-user request hijacking, and cache poisoning on the server path. Response smuggling through an ember-client gateway requires a malicious or compromised upstream. This issue is fixed in versions 0.23.35 and 1.0.0-M47.
Weakness: CWE-444
Which versions are affected by CVE-2026-69205?
10 open source packages ship an affected version, including org.http4s:http4s-ember-core_2.13, org.http4s:http4s-ember-core_2.12 and org.http4s:http4s-ember-core_3.
| Package | Affected | Fixed in |
|---|---|---|
org.http4s:http4s-ember-core_2.13 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-core_2.13 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-core_2.13 Maven | From 1.0.0-M1 | 1.0.0-M47 |
org.http4s:http4s-ember-core_2.13 Maven | From 1.0.0-M1 | 1.0.0-M47 |
org.http4s:http4s-ember-core_2.12 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-core_2.12 Maven | All versions | 0.23.35 |
4 more packages
org.http4s:http4s-ember-core_3 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-core_3 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-core_3 Maven | From 1.0.0-M1 | 1.0.0-M47 |
org.http4s:http4s-ember-core_3 Maven | From 1.0.0-M1 | 1.0.0-M47 |
How do I fix CVE-2026-69205?
Upgrade org.http4s:http4s-ember-core_2.13 to a fixed version for your release line: 0.23.35 or 1.0.0-M47.
Is CVE-2026-69205 being exploited?
There is no known exploitation of CVE-2026-69205 in the wild and no public exploit code.
Sources
Also known as GHSA-9998-894r-fwvr.