# CVE-2026-69206: Http4s: DigestAuth allows replay of captured requests

> Attackers can replay captured HTTP requests to execute authenticated actions as the victim due to flawed nonce-count tracking in Http4s DigestAuth.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-9xww-74xv-gjfp

## What is CVE-2026-69206?

CVE-2026-69206 is a medium-severity vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Http4s is a Scala interface for HTTP services. Prior to 0.23.35 and 1.0.0-M47, DigestAuth replay protection records lastNc plus one instead of the highest nonce-count value it has accepted. When a legitimate client sends noncontiguous nc values because of parallel or retried requests, the stored counter remains below the accepted maximum, allowing a passive observer to replay a captured Authorization header multiple times. Successful replays execute authenticated requests, including state-changing operations, as the captured user. This issue is fixed in versions 0.23.35 and 1.0.0-M47.

Weakness: CWE-294 (Authentication Bypass by Capture-replay)

## Which versions are affected by CVE-2026-69206?

10 open source packages ship an affected version, including org.http4s:http4s-ember-core_2.13, org.http4s:http4s-ember-core_2.12 and org.http4s:http4s-ember-core_3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.http4s:http4s-ember-core_2.13` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-core_2.13` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-core_2.13` | Maven | From 1.0.0-M1 | 1.0.0-M47 |
| `org.http4s:http4s-ember-core_2.13` | Maven | From 1.0.0-M1 | 1.0.0-M47 |
| `org.http4s:http4s-ember-core_2.12` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-core_2.12` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-core_3` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-core_3` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-core_3` | Maven | From 1.0.0-M1 | 1.0.0-M47 |
| `org.http4s:http4s-ember-core_3` | Maven | From 1.0.0-M1 | 1.0.0-M47 |

## How do I fix CVE-2026-69206?

Upgrade org.http4s:http4s-ember-core_2.13 to a fixed version for your release line: 0.23.35 or 1.0.0-M47.

## Is CVE-2026-69206 being exploited?

There is no known exploitation of CVE-2026-69206 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69206 and fix it if it is affected.

What it is: CVE-2026-69206 is a medium-severity vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-69206 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.http4s:http4s-ember-core_2.13 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-core_2.13 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-core_2.13 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47
- org.http4s:http4s-ember-core_2.13 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47
- org.http4s:http4s-ember-core_2.12 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-core_2.12 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-core_3 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-core_3 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-core_3 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47
- org.http4s:http4s-ember-core_3 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69206/ (Markdown: https://insights.sbomify.com/CVE-2026-69206/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69206
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69206
- OSV: https://osv.dev/vulnerability/CVE-2026-69206

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69206/
Summaries are generated and may contain mistakes; the official description above is the record.
