CVE-2026-69208 Http4s: DigestAuth nonce map grows unbounded
An unauthenticated attacker can cause a denial of service by exhausting heap memory in Http4s applications using DigestAuth middleware.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-69208?
CVE-2026-69208 is a high-severity denial of service vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Http4s is a Scala interface for HTTP services. Prior to 0.23.35 and 1.0.0-M47, the DigestAuth server middleware removes fresh nonces and stops eviction at the first stale nonce because its stale-nonce comparison is inverted. On an application that protects at least one route with DigestAuth, an unauthenticated attacker can repeatedly trigger authentication challenges, causing the persistent nonce map to grow until the JVM exhausts heap memory. This issue is fixed in versions 0.23.35 and 1.0.0-M47.
Which versions are affected by CVE-2026-69208?
10 open source packages ship an affected version, including org.http4s:http4s-ember-server_2.13, org.http4s:http4s-ember-server_2.12 and org.http4s:http4s-ember-server_3.
| Package | Affected | Fixed in |
|---|---|---|
org.http4s:http4s-ember-server_2.13 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-server_2.13 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-server_2.13 Maven | From 1.0.0-M1 | 1.0.0-M47 |
org.http4s:http4s-ember-server_2.13 Maven | From 1.0.0-M1 | 1.0.0-M47 |
org.http4s:http4s-ember-server_2.12 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-server_2.12 Maven | All versions | 0.23.35 |
4 more packages
org.http4s:http4s-ember-server_3 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-server_3 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-server_3 Maven | From 1.0.0-M1 | 1.0.0-M47 |
org.http4s:http4s-ember-server_3 Maven | From 1.0.0-M1 | 1.0.0-M47 |
How do I fix CVE-2026-69208?
Upgrade org.http4s:http4s-ember-server_2.13 to a fixed version for your release line: 0.23.35 or 1.0.0-M47.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-69208 being exploited?
There is no known exploitation of CVE-2026-69208 in the wild and no public exploit code.
Sources
Also known as GHSA-fm4g-76c9-7w69.