# CVE-2026-69208: Http4s: DigestAuth nonce map grows unbounded

> An unauthenticated attacker can cause a denial of service by exhausting heap memory in Http4s applications using DigestAuth middleware.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-fm4g-76c9-7w69

## What is CVE-2026-69208?

CVE-2026-69208 is a high-severity denial of service vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Http4s is a Scala interface for HTTP services. Prior to 0.23.35 and 1.0.0-M47, the DigestAuth server middleware removes fresh nonces and stops eviction at the first stale nonce because its stale-nonce comparison is inverted. On an application that protects at least one route with DigestAuth, an unauthenticated attacker can repeatedly trigger authentication challenges, causing the persistent nonce map to grow until the JVM exhausts heap memory. This issue is fixed in versions 0.23.35 and 1.0.0-M47.

Weakness: CWE-401 (Missing Release of Memory after Effective Lifetime), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-69208?

10 open source packages ship an affected version, including org.http4s:http4s-ember-server_2.13, org.http4s:http4s-ember-server_2.12 and org.http4s:http4s-ember-server_3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.http4s:http4s-ember-server_2.13` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-server_2.13` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-server_2.13` | Maven | From 1.0.0-M1 | 1.0.0-M47 |
| `org.http4s:http4s-ember-server_2.13` | Maven | From 1.0.0-M1 | 1.0.0-M47 |
| `org.http4s:http4s-ember-server_2.12` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-server_2.12` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-server_3` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-server_3` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-server_3` | Maven | From 1.0.0-M1 | 1.0.0-M47 |
| `org.http4s:http4s-ember-server_3` | Maven | From 1.0.0-M1 | 1.0.0-M47 |

## How do I fix CVE-2026-69208?

Upgrade org.http4s:http4s-ember-server_2.13 to a fixed version for your release line: 0.23.35 or 1.0.0-M47.

## Is CVE-2026-69208 being exploited?

There is no known exploitation of CVE-2026-69208 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69208 and fix it if it is affected.

What it is: CVE-2026-69208 is a high-severity denial of service vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-69208 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.http4s:http4s-ember-server_2.13 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-server_2.13 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-server_2.13 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47
- org.http4s:http4s-ember-server_2.13 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47
- org.http4s:http4s-ember-server_2.12 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-server_2.12 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-server_3 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-server_3 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-server_3 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47
- org.http4s:http4s-ember-server_3 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69208/ (Markdown: https://insights.sbomify.com/CVE-2026-69208/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69208
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69208
- OSV: https://osv.dev/vulnerability/CVE-2026-69208

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69208/
Summaries are generated and may contain mistakes; the official description above is the record.
