# CVE-2026-69209: Http4s: WebSocket decoder accepts unbounded message sizes

> Remote attackers can exhaust server memory via oversized WebSocket frames in Http4s, causing denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-jrxx-w2m8-5hf5

## What is CVE-2026-69209?

CVE-2026-69209 is a high-severity denial of service vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Http4s is a Scala interface for HTTP services. Prior to 0.23.35 and 1.0.0-M47, The shared WebSocket decoder permits unbounded message buffering because defragmentation accumulates fragments without a limit and FrameTranscoder accepts declared lengths up to Int.MaxValue. A remote client that completes a WebSocket handshake against an http4s-blaze-server or http4s-ember-server endpoint can exhaust server memory with oversized frames or fragmented messages. The patched decoder applies a configurable 64 MiB default limit to individual frames and defragmented messages through EmberServerBuilder.withMaxWebSocketMessageSize. This issue is fixed in versions 0.23.35 and 1.0.0-M47.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-69209?


## How do I fix CVE-2026-69209?

No fix has been published for CVE-2026-69209 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-69209 being exploited?

There is no known exploitation of CVE-2026-69209 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69209 and fix it if it is affected.

What it is: CVE-2026-69209 is a high-severity denial of service vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-69209 in the wild and no public exploit code.

Affected product: http4s. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69209/ (Markdown: https://insights.sbomify.com/CVE-2026-69209/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69209
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69209
- OSV: https://osv.dev/vulnerability/CVE-2026-69209

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69209/
Summaries are generated and may contain mistakes; the official description above is the record.
