# CVE-2026-69210: Http4s: WebSocket decoder accepts negative length, causing infinite decode loop

> A remote attacker can cause a denial of service in Http4s by sending a WebSocket frame with a negative length, triggering an infinite decode loop.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-3j86-pj9g-jchr

## What is CVE-2026-69210?

CVE-2026-69210 is a high-severity denial of service vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Http4s is a Scala interface for HTTP services. Prior to 0.23.35 and 1.0.0-M47, WebSocket FrameTranscoder.bodyLength rejects extended payload lengths above Integer.MAX_VALUE but permits negative 64-bit lengths. A remote client that completes a WebSocket handshake through an Ember server can send such a frame, causing the decoder to return an empty frame without advancing its input. The decode loop then runs indefinitely, pins a worker at full CPU, and grows an ArrayBuffer without bound, resulting in denial of service. This issue is fixed in versions 0.23.35 and 1.0.0-M47.

Weakness: CWE-835 (Loop with Unreachable Exit Condition), CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2026-69210?


## How do I fix CVE-2026-69210?

No fix has been published for CVE-2026-69210 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-69210 being exploited?

There is no known exploitation of CVE-2026-69210 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69210 and fix it if it is affected.

What it is: CVE-2026-69210 is a high-severity denial of service vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-69210 in the wild and no public exploit code.

Affected product: http4s. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69210/ (Markdown: https://insights.sbomify.com/CVE-2026-69210/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69210
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69210
- OSV: https://osv.dev/vulnerability/CVE-2026-69210

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69210/
Summaries are generated and may contain mistakes; the official description above is the record.
