# CVE-2026-69211: Http4s: Set-Cookie rendering does not escape attribute delimiters

> Attackers can inject cookie attributes or split headers via unvalidated input in Http4s, weakening cookie security and potentially enabling header injection.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-7qh7-rghh-698h

## What is CVE-2026-69211?

CVE-2026-69211 is a medium-severity vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Http4s is a Scala interface for HTTP services. Prior to 0.23.35 and 1.0.0-M47, ResponseCookie.render writes attacker-influenced name, content, domain, path, and extension values without neutralizing semicolons or control characters. An application that constructs a ResponseCookie from unvalidated input can therefore emit injected cookie attributes such as Domain, Path, or SameSite, widening cookie scope or weakening protections, and control characters may enable header splitting on permissive backends. The patch strips control characters from all five fields and strips semicolons from name, content, domain, and path while retaining the extension delimiter behavior. This issue is fixed in versions 0.23.35 and 1.0.0-M47.

Weakness: CWE-1286 (Improper Validation of Syntactic Correctness of Input), CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2026-69211?


## How do I fix CVE-2026-69211?

No fix has been published for CVE-2026-69211 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-69211 being exploited?

There is no known exploitation of CVE-2026-69211 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69211 and fix it if it is affected.

What it is: CVE-2026-69211 is a medium-severity vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-69211 in the wild and no public exploit code.

Affected product: http4s. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69211/ (Markdown: https://insights.sbomify.com/CVE-2026-69211/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69211
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69211
- OSV: https://osv.dev/vulnerability/CVE-2026-69211

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69211/
Summaries are generated and may contain mistakes; the official description above is the record.
