CVE-2026-69213 Http4s Ember HTTP/2: unbounded outbound frame queue
An unauthenticated attacker can exhaust server memory by sending HTTP/2 frames that fill an unbounded outbound queue, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-69213?
CVE-2026-69213 is a high-severity denial of service vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Http4s is a Scala interface for HTTP services. Prior to 0.23.35 and 1.0.0-M47, Ember HTTP/2 serializes outbound frames through one unbounded queue consumed by writeLoop. When the peer stops reading, an unauthenticated HTTP/2 client can continue sending PING, SETTINGS, or DATA frames that cause Ember to enqueue acknowledgments or WINDOW_UPDATE frames faster than the writer drains them, exhausting heap memory on a server built with withHttp2. The shared behavior also affects an ember-client connected to a hostile HTTP/2 server, and the patch replaces the unbounded path with bounded, backpressured outbound queues. This issue is fixed in versions 0.23.35 and 1.0.0-M47.
Which versions are affected by CVE-2026-69213?
10 open source packages ship an affected version, including org.http4s:http4s-ember-core_2.13, org.http4s:http4s-ember-core_2.12 and org.http4s:http4s-ember-core_3.
| Package | Affected | Fixed in |
|---|---|---|
org.http4s:http4s-ember-core_2.13 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-core_2.13 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-core_2.13 Maven | From 1.0.0-M1 | 1.0.0-M47 |
org.http4s:http4s-ember-core_2.13 Maven | From 1.0.0-M1 | 1.0.0-M47 |
org.http4s:http4s-ember-core_2.12 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-core_2.12 Maven | All versions | 0.23.35 |
4 more packages
org.http4s:http4s-ember-core_3 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-core_3 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-core_3 Maven | From 1.0.0-M1 | 1.0.0-M47 |
org.http4s:http4s-ember-core_3 Maven | From 1.0.0-M1 | 1.0.0-M47 |
How do I fix CVE-2026-69213?
Upgrade org.http4s:http4s-ember-core_2.13 to a fixed version for your release line: 0.23.35 or 1.0.0-M47.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-69213 being exploited?
There is no known exploitation of CVE-2026-69213 in the wild and no public exploit code.
Sources
Also known as GHSA-8f3q-3jmv-7prw.