# CVE-2026-69214: Http4s: CookieJar middleware accepts arbitrary Set-Cookie domain

> A malicious server can plant cookies for other domains via Http4s CookieJar, enabling session fixation or cookie overwriting.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-wv64-j4fq-5f9x

## What is CVE-2026-69214?

CVE-2026-69214 is a medium-severity vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Http4s is a Scala interface for HTTP services. Prior to 0.23.35 and 1.0.0-M47, The CookieJar client middleware stores a response cookie’s Domain attribute without checking that it domain-matches the host that supplied the cookie or rejecting public suffixes. A malicious or compromised server contacted through the same CookieJar can plant a cookie for another domain, and the jar later sends that cookie to the victim domain, enabling session fixation or overwriting security-sensitive cookies. The patch validates the Set-Cookie domain against the response origin, although public-suffix rejection remains unimplemented. This issue is fixed in versions 0.23.35 and 1.0.0-M47.

Weakness: CWE-565 (Reliance on Cookies without Validation and Integrity Checking), CWE-384 (Session Fixation)

## Which versions are affected by CVE-2026-69214?

10 open source packages ship an affected version, including org.http4s:http4s-client_2.13, org.http4s:http4s-client_2.12 and org.http4s:http4s-client_3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.http4s:http4s-client_2.13` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-client_2.13` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-client_2.13` | Maven | From 1.0.0-M1 | 1.0.0-M47 |
| `org.http4s:http4s-client_2.13` | Maven | From 1.0.0-M1 | 1.0.0-M47 |
| `org.http4s:http4s-client_2.12` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-client_2.12` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-client_3` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-client_3` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-client_3` | Maven | From 1.0.0-M1 | 1.0.0-M47 |
| `org.http4s:http4s-client_3` | Maven | From 1.0.0-M1 | 1.0.0-M47 |

## How do I fix CVE-2026-69214?

Upgrade org.http4s:http4s-client_2.13 to a fixed version for your release line: 0.23.35 or 1.0.0-M47.

## Is CVE-2026-69214 being exploited?

There is no known exploitation of CVE-2026-69214 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69214 and fix it if it is affected.

What it is: CVE-2026-69214 is a medium-severity vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-69214 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.http4s:http4s-client_2.13 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-client_2.13 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-client_2.13 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47
- org.http4s:http4s-client_2.13 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47
- org.http4s:http4s-client_2.12 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-client_2.12 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-client_3 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-client_3 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-client_3 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47
- org.http4s:http4s-client_3 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69214/ (Markdown: https://insights.sbomify.com/CVE-2026-69214/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69214
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69214
- OSV: https://osv.dev/vulnerability/CVE-2026-69214

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69214/
Summaries are generated and may contain mistakes; the official description above is the record.
