CVE-2026-69215 Http4s: CookieJar middleware matches by substring, leaking cookies cross-origin
Http4s library leaks cookies to attacker-controlled domains due to improper substring matching, enabling session hijacking.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-69215?
CVE-2026-69215 is a medium-severity vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Http4s is a Scala interface for HTTP services. Prior to 0.23.35 and 1.0.0-M47, The CookieJar client middleware uses unanchored substring checks instead of RFC 6265 domain and path matching when deciding whether to attach a stored cookie. A cookie for example.com can consequently be sent to an attacker-controlled hostname such as evilexample.com when an application using the same jar makes an attacker-influenced outbound request. This exposes session or authentication cookies and can enable hijacking of the application’s outbound sessions. This issue is fixed in versions 0.23.35 and 1.0.0-M47.
Which versions are affected by CVE-2026-69215?
10 open source packages ship an affected version, including org.http4s:http4s-client_2.13, org.http4s:http4s-client_2.12 and org.http4s:http4s-client_3.
| Package | Affected | Fixed in |
|---|---|---|
org.http4s:http4s-client_2.13 Maven | All versions | 0.23.35 |
org.http4s:http4s-client_2.13 Maven | All versions | 0.23.35 |
org.http4s:http4s-client_2.13 Maven | From 1.0.0-M1 | 1.0.0-M47 |
org.http4s:http4s-client_2.13 Maven | From 1.0.0-M1 | 1.0.0-M47 |
org.http4s:http4s-client_2.12 Maven | All versions | 0.23.35 |
org.http4s:http4s-client_2.12 Maven | All versions | 0.23.35 |
4 more packages
org.http4s:http4s-client_3 Maven | All versions | 0.23.35 |
org.http4s:http4s-client_3 Maven | All versions | 0.23.35 |
org.http4s:http4s-client_3 Maven | From 1.0.0-M1 | 1.0.0-M47 |
org.http4s:http4s-client_3 Maven | From 1.0.0-M1 | 1.0.0-M47 |
How do I fix CVE-2026-69215?
Upgrade org.http4s:http4s-client_2.13 to a fixed version for your release line: 0.23.35 or 1.0.0-M47.
Is CVE-2026-69215 being exploited?
There is no known exploitation of CVE-2026-69215 in the wild and no public exploit code.
Sources
Also known as GHSA-grh8-3p95-f9rr.