# CVE-2026-69215: Http4s: CookieJar middleware matches by substring, leaking cookies cross-origin

> Http4s library leaks cookies to attacker-controlled domains due to improper substring matching, enabling session hijacking.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-grh8-3p95-f9rr

## What is CVE-2026-69215?

CVE-2026-69215 is a medium-severity vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Http4s is a Scala interface for HTTP services. Prior to 0.23.35 and 1.0.0-M47, The CookieJar client middleware uses unanchored substring checks instead of RFC 6265 domain and path matching when deciding whether to attach a stored cookie. A cookie for example.com can consequently be sent to an attacker-controlled hostname such as evilexample.com when an application using the same jar makes an attacker-influenced outbound request. This exposes session or authentication cookies and can enable hijacking of the application’s outbound sessions. This issue is fixed in versions 0.23.35 and 1.0.0-M47.

Weakness: CWE-565 (Reliance on Cookies without Validation and Integrity Checking), CWE-1275 (Sensitive Cookie with Improper SameSite Attribute)

## Which versions are affected by CVE-2026-69215?

10 open source packages ship an affected version, including org.http4s:http4s-client_2.13, org.http4s:http4s-client_2.12 and org.http4s:http4s-client_3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.http4s:http4s-client_2.13` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-client_2.13` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-client_2.13` | Maven | From 1.0.0-M1 | 1.0.0-M47 |
| `org.http4s:http4s-client_2.13` | Maven | From 1.0.0-M1 | 1.0.0-M47 |
| `org.http4s:http4s-client_2.12` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-client_2.12` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-client_3` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-client_3` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-client_3` | Maven | From 1.0.0-M1 | 1.0.0-M47 |
| `org.http4s:http4s-client_3` | Maven | From 1.0.0-M1 | 1.0.0-M47 |

## How do I fix CVE-2026-69215?

Upgrade org.http4s:http4s-client_2.13 to a fixed version for your release line: 0.23.35 or 1.0.0-M47.

## Is CVE-2026-69215 being exploited?

There is no known exploitation of CVE-2026-69215 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69215 and fix it if it is affected.

What it is: CVE-2026-69215 is a medium-severity vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-69215 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.http4s:http4s-client_2.13 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-client_2.13 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-client_2.13 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47
- org.http4s:http4s-client_2.13 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47
- org.http4s:http4s-client_2.12 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-client_2.12 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-client_3 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-client_3 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-client_3 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47
- org.http4s:http4s-client_3 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69215/ (Markdown: https://insights.sbomify.com/CVE-2026-69215/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69215
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69215
- OSV: https://osv.dev/vulnerability/CVE-2026-69215

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69215/
Summaries are generated and may contain mistakes; the official description above is the record.
