CVE-2026-69216 Http4s: Ember chunk parser lenience (TE.TE request smuggling)
An attacker can exploit lenient chunk parsing in Http4s Ember to perform request smuggling, bypassing intermediary controls and poisoning caches.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-69216?
CVE-2026-69216 is a medium-severity vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Http4s is a Scala interface for HTTP services. Prior to 0.23.35 and 1.0.0-M47, Ember’s chunk decoder trims the chunk-size token and accepts leading plus or minus signs instead of requiring one or more hexadecimal digits followed by the required CRLF. When an intermediary forwards chunked data without re-encoding and interprets malformed chunk boundaries differently, an unauthenticated attacker can create TE.TE request smuggling that bypasses intermediary controls, poisons caches, or hijacks the request queue. The same response-path leniency can enable response smuggling against an ember-client used as a gateway when the upstream is malicious or compromised. This issue is fixed in versions 0.23.35 and 1.0.0-M47.
Weakness: CWE-444
Which versions are affected by CVE-2026-69216?
10 open source packages ship an affected version, including org.http4s:http4s-ember-core_2.13, org.http4s:http4s-ember-core_2.12 and org.http4s:http4s-ember-core_3.
| Package | Affected | Fixed in |
|---|---|---|
org.http4s:http4s-ember-core_2.13 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-core_2.13 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-core_2.13 Maven | From 1.0.0-M1 | 1.0.0-M47 |
org.http4s:http4s-ember-core_2.13 Maven | From 1.0.0-M1 | 1.0.0-M47 |
org.http4s:http4s-ember-core_2.12 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-core_2.12 Maven | All versions | 0.23.35 |
4 more packages
org.http4s:http4s-ember-core_3 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-core_3 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-core_3 Maven | From 1.0.0-M1 | 1.0.0-M47 |
org.http4s:http4s-ember-core_3 Maven | From 1.0.0-M1 | 1.0.0-M47 |
How do I fix CVE-2026-69216?
Upgrade org.http4s:http4s-ember-core_2.13 to a fixed version for your release line: 0.23.35 or 1.0.0-M47.
Is CVE-2026-69216 being exploited?
There is no known exploitation of CVE-2026-69216 in the wild and no public exploit code.
Sources
Also known as GHSA-jrpm-956j-96jg.