CVE-2026-69218 Http4s Ember HTTP/2: unbounded continuation frame accumulation
Remote attackers can exhaust heap memory in Http4s Ember HTTP/2 servers or clients by sending unbounded continuation frames, causing denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-69218?
CVE-2026-69218 is a high-severity denial of service vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Http4s is a Scala interface for HTTP services. Prior to 0.23.35 and 1.0.0-M47, When Ember receives an HTTP/2 HEADERS or PUSH_PROMISE frame without END_HEADERS, H2Connection buffers the header block and subsequent CONTINUATION fragments without a size bound. A remote peer can keep an incomplete block open and exhaust heap memory before request decoding, affecting an ember-server or ember-client configured with withHttp2. The remediation tracks accumulated size against SETTINGS_MAX_HEADER_LIST_SIZE derived from EmberServerBuilder.maxHeaderSize or EmberClientBuilder.maxResponseHeaderSize, sends GOAWAY when the limit is exceeded, and applies receiveHeadersTimeout to incomplete blocks. This issue is fixed in versions 0.23.35 and 1.0.0-M47.
Weakness: CWE-770
Which versions are affected by CVE-2026-69218?
10 open source packages ship an affected version, including org.http4s:http4s-ember-core_2.13, org.http4s:http4s-ember-core_2.12 and org.http4s:http4s-ember-core_3.
| Package | Affected | Fixed in |
|---|---|---|
org.http4s:http4s-ember-core_2.13 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-core_2.13 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-core_2.13 Maven | From 1.0.0-M1 | 1.0.0-M47 |
org.http4s:http4s-ember-core_2.13 Maven | From 1.0.0-M1 | 1.0.0-M47 |
org.http4s:http4s-ember-core_2.12 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-core_2.12 Maven | All versions | 0.23.35 |
4 more packages
org.http4s:http4s-ember-core_3 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-core_3 Maven | All versions | 0.23.35 |
org.http4s:http4s-ember-core_3 Maven | From 1.0.0-M1 | 1.0.0-M47 |
org.http4s:http4s-ember-core_3 Maven | From 1.0.0-M1 | 1.0.0-M47 |
How do I fix CVE-2026-69218?
Upgrade org.http4s:http4s-ember-core_2.13 to a fixed version for your release line: 0.23.35 or 1.0.0-M47.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-69218 being exploited?
There is no known exploitation of CVE-2026-69218 in the wild and no public exploit code.
Sources
Also known as GHSA-cp4q-fqw9-4hf6.