# CVE-2026-69218: Http4s Ember HTTP/2: unbounded continuation frame accumulation

> Remote attackers can exhaust heap memory in Http4s Ember HTTP/2 servers or clients by sending unbounded continuation frames, causing denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-cp4q-fqw9-4hf6

## What is CVE-2026-69218?

CVE-2026-69218 is a high-severity denial of service vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Http4s is a Scala interface for HTTP services. Prior to 0.23.35 and 1.0.0-M47, When Ember receives an HTTP/2 HEADERS or PUSH_PROMISE frame without END_HEADERS, H2Connection buffers the header block and subsequent CONTINUATION fragments without a size bound. A remote peer can keep an incomplete block open and exhaust heap memory before request decoding, affecting an ember-server or ember-client configured with withHttp2. The remediation tracks accumulated size against SETTINGS_MAX_HEADER_LIST_SIZE derived from EmberServerBuilder.maxHeaderSize or EmberClientBuilder.maxResponseHeaderSize, sends GOAWAY when the limit is exceeded, and applies receiveHeadersTimeout to incomplete blocks. This issue is fixed in versions 0.23.35 and 1.0.0-M47.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-69218?

10 open source packages ship an affected version, including org.http4s:http4s-ember-core_2.13, org.http4s:http4s-ember-core_2.12 and org.http4s:http4s-ember-core_3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.http4s:http4s-ember-core_2.13` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-core_2.13` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-core_2.13` | Maven | From 1.0.0-M1 | 1.0.0-M47 |
| `org.http4s:http4s-ember-core_2.13` | Maven | From 1.0.0-M1 | 1.0.0-M47 |
| `org.http4s:http4s-ember-core_2.12` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-core_2.12` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-core_3` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-core_3` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-core_3` | Maven | From 1.0.0-M1 | 1.0.0-M47 |
| `org.http4s:http4s-ember-core_3` | Maven | From 1.0.0-M1 | 1.0.0-M47 |

## How do I fix CVE-2026-69218?

Upgrade org.http4s:http4s-ember-core_2.13 to a fixed version for your release line: 0.23.35 or 1.0.0-M47.

## Is CVE-2026-69218 being exploited?

There is no known exploitation of CVE-2026-69218 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69218 and fix it if it is affected.

What it is: CVE-2026-69218 is a high-severity denial of service vulnerability in http4s, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-69218 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.http4s:http4s-ember-core_2.13 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-core_2.13 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-core_2.13 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47
- org.http4s:http4s-ember-core_2.13 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47
- org.http4s:http4s-ember-core_2.12 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-core_2.12 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-core_3 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-core_3 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-core_3 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47
- org.http4s:http4s-ember-core_3 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69218/ (Markdown: https://insights.sbomify.com/CVE-2026-69218/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69218
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69218
- OSV: https://osv.dev/vulnerability/CVE-2026-69218

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69218/
Summaries are generated and may contain mistakes; the official description above is the record.
