{"answers":{"affected":"2 open source packages ship an affected version, including com.rabbitmq:amqp-client.","exploited":"There is no known exploitation of CVE-2026-69219 in the wild and no public exploit code.","fix":"Upgrade com.rabbitmq:amqp-client to 5.33.1 or later.","what":"CVE-2026-69219 is a high-severity denial of service vulnerability in rabbitmq-java-client, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-69219 and fix it if it is affected.\n\nWhat it is: CVE-2026-69219 is a high-severity denial of service vulnerability in rabbitmq-java-client, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-69219 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.rabbitmq:amqp-client (Maven): affected all versions; fixed in 5.33.1\n- com.rabbitmq:amqp-client (Maven): affected all versions; fixed in 5.33.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-69219/ (Markdown: https://insights.sbomify.com/CVE-2026-69219/index.md)","id":"CVE-2026-69219","markdown":"https://insights.sbomify.com/CVE-2026-69219/index.md","name":"CVE-2026-69219","record":{"aliases":["CLEANSTART-2026-BN21092","CLSA-2026-1789372046","CLSA-2026-1792593562","CLSA-2026-1792593590","DEBIAN-CVE-2026-69219","ECHO-aed7-1329-6abc","GHSA-68mj-5wr7-6fgg","MINI-269j-93hh-2f99","MINI-2fxr-32w5-549x","MINI-2pfr-w5j8-6rgh","MINI-495w-r8pj-j393","MINI-5x6h-ppv5-fhww","MINI-6jx9-g65h-6995","MINI-87gv-m839-wr8x","MINI-c594-352g-rjv5","MINI-fx8p-rfv9-f7hx","MINI-gmc6-phg6-rg94","MINI-jfjp-p878-r3xc","MINI-rfwh-7pvq-jp42","MINI-xgv8-5959-958m","MINI-xgwm-q9w6-8j3g","MINI-xrm4-2555-vgh2","ROOT-APP-MAVEN-CVE-2026-69219","UBUNTU-CVE-2026-69219"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"RabbitMQ Java client","requires_auth":"none","summary":"A malicious AMQP peer can trigger an OutOfMemoryError in the RabbitMQ Java client by sending oversized length declarations, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-789","name":"Memory Allocation with Excessive Size Value"}],"description":"The RabbitMQ Java client library allows Java and JVM-based applications to connect to and interact with RabbitMQ nodes. Prior to 5.33.1, src/main/java/com/rabbitmq/client/impl/ValueReader.java uses ValueReader.readBytes to accept a wire-declared contentLength below Integer.MAX_VALUE and allocate a byte array before checking the bytes available in the frame. A malicious AMQP peer can send a LongString or byte-array field with type tag S and a declared length such as 0x7FFFFFFE during the pre-authentication connection.start server-properties table, causing an approximately 2 GB allocation and OutOfMemoryError before readFully consumes data. The resulting memory exhaustion can terminate the JVM and cause denial of service. This issue is fixed in version 5.33.1.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RabbitMQ Java client ValueReader: Oversized LongString/bytes length triggers OOM via unchecked allocation","id":"CVE-2026-69219","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":6,"next":{"headline":"RabbitMQ Java client ValueReader: Unbounded recursive table/array nesting causes StackOverflowError DoS","id":"CVE-2026-69220"},"packages":[{"ecosystem":"Maven","fixed":["5.33.1"],"introduced":["0"],"last_affected":[],"package":"com.rabbitmq:amqp-client","purl":null,"source":"GHSA-68mj-5wr7-6fgg"},{"ecosystem":"Maven","fixed":["5.33.1"],"introduced":["0"],"last_affected":[],"package":"com.rabbitmq:amqp-client","purl":"pkg:maven/com.rabbitmq/amqp-client","source":"GHSA-68mj-5wr7-6fgg"}],"prev":{"headline":"Http4s Ember HTTP/2: unbounded continuation frame accumulation","id":"CVE-2026-69218"},"products":["rabbitmq-java-client"],"published":"2026-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-19","vendors":["rabbitmq"]},"summary":"A malicious AMQP peer can trigger an OutOfMemoryError in the RabbitMQ Java client by sending oversized length declarations, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2026-69219/"}