{"answers":{"affected":"2 open source packages ship an affected version, including com.rabbitmq:amqp-client.","exploited":"There is no known exploitation of CVE-2026-69220 in the wild and no public exploit code.","fix":"Upgrade com.rabbitmq:amqp-client to 5.33.1 or later.","what":"CVE-2026-69220 is a high-severity denial of service vulnerability in rabbitmq-java-client, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-69220 and fix it if it is affected.\n\nWhat it is: CVE-2026-69220 is a high-severity denial of service vulnerability in rabbitmq-java-client, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-69220 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.rabbitmq:amqp-client (Maven): affected all versions; fixed in 5.33.1\n- com.rabbitmq:amqp-client (Maven): affected all versions; fixed in 5.33.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-69220/ (Markdown: https://insights.sbomify.com/CVE-2026-69220/index.md)","id":"CVE-2026-69220","markdown":"https://insights.sbomify.com/CVE-2026-69220/index.md","name":"CVE-2026-69220","record":{"aliases":["CLEANSTART-2026-OM34556","DEBIAN-CVE-2026-69220","ECHO-c1b2-abe7-d717","GHSA-93j5-89vc-pph4","MINI-237x-2m6x-phqg","MINI-5rh9-c4cp-32w6","MINI-5xpq-937p-78gh","MINI-64r7-wc75-vrwg","MINI-83gw-mjw4-f5p8","MINI-89r7-p376-mpfq","MINI-cvx9-662h-5g6w","MINI-f2m4-8vf7-p2h3","MINI-fcwm-4rpm-943j","MINI-fhmq-c893-7xx3","MINI-j45f-wc7f-pgf7","MINI-pmg5-x8wj-94q2","MINI-q724-v2p7-w68q","MINI-r6gx-hpp5-vpq2","MINI-rpcp-6889-9r99","ROOT-APP-MAVEN-CVE-2026-69220","UBUNTU-CVE-2026-69220"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"RabbitMQ Java client","requires_auth":"none","summary":"A malicious AMQP server can cause a StackOverflowError in the RabbitMQ Java client, leading to denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"The RabbitMQ Java client library allows Java and JVM-based applications to connect to and interact with RabbitMQ nodes. Prior to 5.33.1, src/main/java/com/rabbitmq/client/impl/ValueReader.java permits ValueReader.readTable and ValueReader.readArray to call ValueReader.readFieldValue recursively for AMQP table type F and AMQP array type A values without a nesting-depth limit. A malicious AMQP server or network intermediary can send approximately 580 nested table levels in the pre-authentication connection.start frame, fitting within the default 131072-byte frame maximum, to trigger StackOverflowError. The error terminates the client input processing thread and causes denial of service. This issue is fixed in version 5.33.1.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RabbitMQ Java client ValueReader: Unbounded recursive table/array nesting causes StackOverflowError DoS","id":"CVE-2026-69220","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":6,"next":{"headline":"LiquidJS: Uncontrolled Resource Consumption in `join` filter allows template authors to bypass `memoryLimit` and crash the process","id":"CVE-2026-69222"},"packages":[{"ecosystem":"Maven","fixed":["5.33.1"],"introduced":["0"],"last_affected":[],"package":"com.rabbitmq:amqp-client","purl":null,"source":"GHSA-93j5-89vc-pph4"},{"ecosystem":"Maven","fixed":["5.33.1"],"introduced":["0"],"last_affected":[],"package":"com.rabbitmq:amqp-client","purl":"pkg:maven/com.rabbitmq/amqp-client","source":"GHSA-93j5-89vc-pph4"}],"prev":{"headline":"RabbitMQ Java client ValueReader: Oversized LongString/bytes length triggers OOM via unchecked allocation","id":"CVE-2026-69219"},"products":["rabbitmq-java-client"],"published":"2026-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-18","vendors":["rabbitmq"]},"summary":"A malicious AMQP server can cause a StackOverflowError in the RabbitMQ Java client, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2026-69220/"}