# CVE-2026-69220: RabbitMQ Java client ValueReader: Unbounded recursive table/array nesting causes StackOverflowError DoS

> A malicious AMQP server can cause a StackOverflowError in the RabbitMQ Java client, leading to denial of service.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** CLEANSTART-2026-OM34556, DEBIAN-CVE-2026-69220, ECHO-c1b2-abe7-d717, GHSA-93j5-89vc-pph4, MINI-237x-2m6x-phqg, MINI-5rh9-c4cp-32w6, MINI-5xpq-937p-78gh, MINI-64r7-wc75-vrwg, MINI-83gw-mjw4-f5p8, MINI-89r7-p376-mpfq, MINI-cvx9-662h-5g6w, MINI-f2m4-8vf7-p2h3, MINI-fcwm-4rpm-943j, MINI-fhmq-c893-7xx3, MINI-j45f-wc7f-pgf7, MINI-pmg5-x8wj-94q2, MINI-q724-v2p7-w68q, MINI-r6gx-hpp5-vpq2, MINI-rpcp-6889-9r99, ROOT-APP-MAVEN-CVE-2026-69220, UBUNTU-CVE-2026-69220

## What is CVE-2026-69220?

CVE-2026-69220 is a high-severity denial of service vulnerability in rabbitmq-java-client, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The RabbitMQ Java client library allows Java and JVM-based applications to connect to and interact with RabbitMQ nodes. Prior to 5.33.1, src/main/java/com/rabbitmq/client/impl/ValueReader.java permits ValueReader.readTable and ValueReader.readArray to call ValueReader.readFieldValue recursively for AMQP table type F and AMQP array type A values without a nesting-depth limit. A malicious AMQP server or network intermediary can send approximately 580 nested table levels in the pre-authentication connection.start frame, fitting within the default 131072-byte frame maximum, to trigger StackOverflowError. The error terminates the client input processing thread and causes denial of service. This issue is fixed in version 5.33.1.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-69220?

2 open source packages ship an affected version, including com.rabbitmq:amqp-client.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.rabbitmq:amqp-client` | Maven | All versions | 5.33.1 |
| `com.rabbitmq:amqp-client` | Maven | All versions | 5.33.1 |

## How do I fix CVE-2026-69220?

Upgrade com.rabbitmq:amqp-client to 5.33.1 or later.

## Is CVE-2026-69220 being exploited?

There is no known exploitation of CVE-2026-69220 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69220 and fix it if it is affected.

What it is: CVE-2026-69220 is a high-severity denial of service vulnerability in rabbitmq-java-client, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-69220 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.rabbitmq:amqp-client (Maven): affected all versions; fixed in 5.33.1
- com.rabbitmq:amqp-client (Maven): affected all versions; fixed in 5.33.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69220/ (Markdown: https://insights.sbomify.com/CVE-2026-69220/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69220
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69220
- OSV: https://osv.dev/vulnerability/CVE-2026-69220

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69220/
Summaries are generated and may contain mistakes; the official description above is the record.
