{"answers":{"affected":"2 open source packages ship an affected version, including sequelize.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69240 exists.","fix":"Upgrade sequelize to 6.37.4 or later.","what":"CVE-2026-69240 is a critical SQL injection vulnerability in sequelize, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-69240 and fix it if it is affected.\n\nWhat it is: CVE-2026-69240 is a critical SQL injection vulnerability in sequelize, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69240 exists.\n\nAffected packages and fixed versions:\n- sequelize (npm): affected all versions; fixed in 6.37.4\n- sequelize (npm): affected all versions; fixed in 6.37.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-69240/ (Markdown: https://insights.sbomify.com/CVE-2026-69240/index.md)","id":"CVE-2026-69240","markdown":"https://insights.sbomify.com/CVE-2026-69240/index.md","name":"CVE-2026-69240","record":{"aliases":["GHSA-v8fg-2rw7-q452"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js ORM library","requires_auth":"none","summary":"Attackers can inject arbitrary SQL via specific string inputs when using the Oracle dialect, requiring an upgrade to the Sequelize library.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Sequelize is a Node.js ORM tool. Prior to 6.37.4, SQL injection is possible with strings only if dialect is set to oracle. The escape function defined in sql-string.js does not escape quotes if the value starts with TO_TIMESTAMP or TO_DATE. In the Oracle dialect, when val is a string and starts with TO_TIMESTAMP or TO_DATE, escape returns val directly instead of replacing single quotes. An attacker can inject arbitrary SQL expressions through an application value that reaches this escape path. This issue is fixed in version 6.37.4.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Sequelize: SQL Injection (Oracle DB)","id":"CVE-2026-69240","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"sql_injection","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"libvips: Integer overflow leading to heap buffer overflow leading to possible attacker-controlled mmap-resident write","id":"CVE-2026-69242"},"packages":[{"ecosystem":"npm","fixed":["6.37.4"],"introduced":["0"],"last_affected":[],"package":"sequelize","purl":null,"source":"GHSA-v8fg-2rw7-q452"},{"ecosystem":"npm","fixed":["6.37.4"],"introduced":["0"],"last_affected":[],"package":"sequelize","purl":"pkg:npm/sequelize","source":"GHSA-v8fg-2rw7-q452"}],"prev":{"headline":"HTML injection vulnerability in Esri Portal for ArcGIS","id":"CVE-2026-69238"},"products":["sequelize"],"published":"2026-08-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-04","vendors":["sequelize"]},"summary":"Attackers can inject arbitrary SQL via specific string inputs when using the Oracle dialect, requiring an upgrade to the Sequelize library.","url":"https://insights.sbomify.com/CVE-2026-69240/"}