# CVE-2026-69240: Sequelize: SQL Injection (Oracle DB)

> Attackers can inject arbitrary SQL via specific string inputs when using the Oracle dialect, requiring an upgrade to the Sequelize library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Aug 2026
- **Updated:** 4 Aug 2026
- **Also known as:** GHSA-v8fg-2rw7-q452

## What is CVE-2026-69240?

CVE-2026-69240 is a critical SQL injection vulnerability in sequelize, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Sequelize is a Node.js ORM tool. Prior to 6.37.4, SQL injection is possible with strings only if dialect is set to oracle. The escape function defined in sql-string.js does not escape quotes if the value starts with TO_TIMESTAMP or TO_DATE. In the Oracle dialect, when val is a string and starts with TO_TIMESTAMP or TO_DATE, escape returns val directly instead of replacing single quotes. An attacker can inject arbitrary SQL expressions through an application value that reaches this escape path. This issue is fixed in version 6.37.4.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-69240?

2 open source packages ship an affected version, including sequelize.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sequelize` | npm | All versions | 6.37.4 |
| `sequelize` | npm | All versions | 6.37.4 |

## How do I fix CVE-2026-69240?

Upgrade sequelize to 6.37.4 or later.

## Is CVE-2026-69240 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69240 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69240 and fix it if it is affected.

What it is: CVE-2026-69240 is a critical SQL injection vulnerability in sequelize, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69240 exists.

Affected packages and fixed versions:
- sequelize (npm): affected all versions; fixed in 6.37.4
- sequelize (npm): affected all versions; fixed in 6.37.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69240/ (Markdown: https://insights.sbomify.com/CVE-2026-69240/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69240
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69240
- OSV: https://osv.dev/vulnerability/CVE-2026-69240

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69240/
Summaries are generated and may contain mistakes; the official description above is the record.
