# CVE-2026-69242: libvips: Integer overflow leading to heap buffer overflow leading to possible attacker-controlled mmap-resident write

> A crafted TIFF file can trigger an integer overflow in libvips, leading to heap buffer overflows, potential data disclosure, and possible remote code execution.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:H/SC:L/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-69242, GHSA-9rwc-f68v-4482, UBUNTU-CVE-2026-69242

## What is CVE-2026-69242?

CVE-2026-69242 is a high-severity vulnerability in libvips, published on 20 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, a crafted many-band TIFF processed through VipsForeignLoadTiff can evade scanline validation in libvips/iofuncs/image.c and cause an integer overflow in vips_image_sanity. The resulting buffer-region calculation can access attacker-controlled negative offsets in mmap-resident allocations, allowing reads or writes of other image data, possible data disclosure through uncompressed .v output, and likely process crashes. Remote code execution has not been demonstrated but cannot be ruled out. This issue is fixed in version 8.18.3.

Weakness: CWE-190 (Integer Overflow or Wraparound), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2026-69242?


## How do I fix CVE-2026-69242?

Upgrade to a fixed version.

## Is CVE-2026-69242 being exploited?

There is no known exploitation of CVE-2026-69242 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69242 and fix it if it is affected.

What it is: CVE-2026-69242 is a high-severity vulnerability in libvips, published on 20 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-69242 in the wild and no public exploit code.

Affected product: libvips. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69242/ (Markdown: https://insights.sbomify.com/CVE-2026-69242/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69242
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69242
- OSV: https://osv.dev/vulnerability/CVE-2026-69242

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69242/
Summaries are generated and may contain mistakes; the official description above is the record.
