CVE-2026-69245 Guzzle: Noncanonical cookie domain keeps subdomain scope

Medium 6.5 Published Updated

Attackers can steal session cookies or inject state by exploiting non-canonical IP domain parsing in Guzzle's cookie handling.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-69245?

CVE-2026-69245 is a medium-severity vulnerability in guzzle, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Guzzle is an extensible PHP HTTP client. Prior to 7.15.2 and 8.0.1, SetCookie::matchesDomain() gives every subdomain of a cookie Domain that cookie unless SetCookie::matchesDomain() recognizes the Domain as an IP literal or a numeric host, and the decision comes from the domain's own text, so two spellings a transport reads as an address keep subdomain scope. Hexadecimal and mixed-base forms such as 0x7f000001 and 0177.0.0.0x1 go unrecognized while libcurl 8.21.0 reads both as 127.0.0.1. A percent-escaped Domain keeps that scope on both branches because percent-decoding sits above numeric parsing, so 192.168.0.%31 and 127.0.0.1%2e are registered names in the URI grammar rather than address literals, and no numeric rule in any base classifies them, while libcurl decodes the host before resolving and reads them as 192.168.0.1 and 127.0.0.1. A cookie stored for Domain=0x7f000001 is placed in the Cookie header of a request to evil.0x7f000001, disclosing a session identifier or token to a host that is not that address, and a response from evil.0x7f000001 setting Domain=0x7f000001 is accepted into the jar and replayed to the address, so a server answering for the look-alike name can fix a session or set application state. Exploitation requires the application to enable cookie support, address an origin by one of these spellings, and contact a host whose name ends in that spelling. This issue is fixed in versions 7.15.2 and 8.0.1.

Weakness: CWE-384, CWE-346, CWE-180

Which versions are affected by CVE-2026-69245?

4 open source packages ship an affected version, including guzzlehttp/guzzle.

PackageAffectedFixed in
guzzlehttp/guzzle PackagistAll versions7.15.2
guzzlehttp/guzzle PackagistAll versions7.15.2
guzzlehttp/guzzle PackagistFrom 8.0.08.0.1
guzzlehttp/guzzle PackagistFrom 8.0.08.0.1

How do I fix CVE-2026-69245?

Upgrade guzzlehttp/guzzle to a fixed version for your release line: 7.15.2 or 8.0.1.

Is CVE-2026-69245 being exploited?

There is no known exploitation of CVE-2026-69245 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-69245, GHSA-f7vp-7xgx-4w4r, MINI-4jfq-m283-7wxh, MINI-4jfr-272v-q4hr, MINI-73vw-7jqq-3fcf, MINI-h3r4-h2mq-mf78 and 3 more.

Is CVE-2026-69245 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free