# CVE-2026-69245: Guzzle: Noncanonical cookie domain keeps subdomain scope

> Attackers can steal session cookies or inject state by exploiting non-canonical IP domain parsing in Guzzle's cookie handling.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Aug 2026
- **Updated:** 4 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-69245, GHSA-f7vp-7xgx-4w4r, MINI-4jfq-m283-7wxh, MINI-4jfr-272v-q4hr, MINI-73vw-7jqq-3fcf, MINI-h3r4-h2mq-mf78, MINI-mqh2-6wr6-gx9x, MINI-qr54-62pr-vvr7, UBUNTU-CVE-2026-69245

## What is CVE-2026-69245?

CVE-2026-69245 is a medium-severity vulnerability in guzzle, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Guzzle is an extensible PHP HTTP client. Prior to 7.15.2 and 8.0.1, SetCookie::matchesDomain() gives every subdomain of a cookie Domain that cookie unless SetCookie::matchesDomain() recognizes the Domain as an IP literal or a numeric host, and the decision comes from the domain's own text, so two spellings a transport reads as an address keep subdomain scope. Hexadecimal and mixed-base forms such as 0x7f000001 and 0177.0.0.0x1 go unrecognized while libcurl 8.21.0 reads both as 127.0.0.1. A percent-escaped Domain keeps that scope on both branches because percent-decoding sits above numeric parsing, so 192.168.0.%31 and 127.0.0.1%2e are registered names in the URI grammar rather than address literals, and no numeric rule in any base classifies them, while libcurl decodes the host before resolving and reads them as 192.168.0.1 and 127.0.0.1. A cookie stored for Domain=0x7f000001 is placed in the Cookie header of a request to evil.0x7f000001, disclosing a session identifier or token to a host that is not that address, and a response from evil.0x7f000001 setting Domain=0x7f000001 is accepted into the jar and replayed to the address, so a server answering for the look-alike name can fix a session or set application state. Exploitation requires the application to enable cookie support, address an origin by one of these spellings, and contact a host whose name ends in that spelling. This issue is fixed in versions 7.15.2 and 8.0.1.

Weakness: CWE-384 (Session Fixation), CWE-346 (Origin Validation Error), CWE-180 (Incorrect Behavior Order: Validate Before Canonicalize)

## Which versions are affected by CVE-2026-69245?

4 open source packages ship an affected version, including guzzlehttp/guzzle.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `guzzlehttp/guzzle` | Packagist | All versions | 7.15.2 |
| `guzzlehttp/guzzle` | Packagist | All versions | 7.15.2 |
| `guzzlehttp/guzzle` | Packagist | From 8.0.0 | 8.0.1 |
| `guzzlehttp/guzzle` | Packagist | From 8.0.0 | 8.0.1 |

## How do I fix CVE-2026-69245?

Upgrade guzzlehttp/guzzle to a fixed version for your release line: 7.15.2 or 8.0.1.

## Is CVE-2026-69245 being exploited?

There is no known exploitation of CVE-2026-69245 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69245 and fix it if it is affected.

What it is: CVE-2026-69245 is a medium-severity vulnerability in guzzle, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-69245 in the wild and no public exploit code.

Affected packages and fixed versions:
- guzzlehttp/guzzle (Packagist): affected all versions; fixed in 7.15.2
- guzzlehttp/guzzle (Packagist): affected all versions; fixed in 7.15.2
- guzzlehttp/guzzle (Packagist): affected from 8.0.0; fixed in 8.0.1
- guzzlehttp/guzzle (Packagist): affected from 8.0.0; fixed in 8.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69245/ (Markdown: https://insights.sbomify.com/CVE-2026-69245/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69245
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69245
- OSV: https://osv.dev/vulnerability/CVE-2026-69245

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69245/
Summaries are generated and may contain mistakes; the official description above is the record.
