CVE-2026-69246 Guzzle: Noncanonical host can bypass host-based checks
Attackers can bypass host-based security checks in Guzzle by using noncanonical host formats, allowing access to restricted internal hosts and reading sensitive data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-69246?
CVE-2026-69246 is a high-severity server-side request forgery vulnerability in guzzle, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Guzzle is an extensible PHP HTTP client. Prior to 7.15.2 and 8.0.1, Guzzle gives a transport the request URI as text and supplies the Host header separately. The cURL handlers set CURLOPT_URL to the URI exactly as written and push that Host into CURLOPT_HTTPHEADER; StreamHandler does the same through fopen(). libcurl then parses the authority itself, percent-decoding it and, on an IDN-capable build, applying IDNA mapping, and uses the result to resolve, connect, name the TLS peer and address a proxy CONNECT, while the supplied Host suppresses the aligned one libcurl would have generated. For a URI host written as 127.0.0.%31, filter_var() rejects the host as an IP literal, yet libcurl decodes it to 127.0.0.1 and reaches loopback with no DNS lookup while the server receives Host: 127.0.0.%31. An attacker who influences a fetched URI can therefore reach a host the application's checks excluded and read whatever the host exposes of the response. The same divergence moves Guzzle's own decisions onto a spelling the transport does not use: no_proxy selects proxy routing from the literal host, and RedirectMiddleware decides from it whether to strip Authorization and Cookie. Exploitation requires the application to build a request URI from untrusted input and to make a host decision before handing it to Guzzle. This issue is fixed in versions 7.15.2 and 8.0.1.
Which versions are affected by CVE-2026-69246?
4 open source packages ship an affected version, including guzzlehttp/guzzle.
| Package | Affected | Fixed in |
|---|---|---|
guzzlehttp/guzzle Packagist | All versions | 7.15.2 |
guzzlehttp/guzzle Packagist | All versions | 7.15.2 |
guzzlehttp/guzzle Packagist | From 8.0.0 | 8.0.1 |
guzzlehttp/guzzle Packagist | From 8.0.0 | 8.0.1 |
How do I fix CVE-2026-69246?
Upgrade guzzlehttp/guzzle to a fixed version for your release line: 7.15.2 or 8.0.1.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-69246 being exploited?
There is no known exploitation of CVE-2026-69246 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2026-69246, GHSA-v5mv-p594-2x33, MINI-3hpr-xgqh-ggg2, MINI-4w97-j53p-c939, MINI-7pv7-4m4g-q3hx, MINI-m58m-8267-xh7g and 3 more.