# CVE-2026-69247: cryptography: PKCS#7 EnvelopedData decryption exposes a Bleichenbacher oracle through distinguishable errors and timing

> Attackers can exploit a Bleichenbacher oracle in PKCS#7 decryption to recover content-encryption keys, compromising data confidentiality in applications processing untrusted S/MIME or PKCS#7 data.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Aug 2026
- **Updated:** 4 Aug 2026
- **Also known as:** CLEANSTART-2026-SR43312, CLEANSTART-2026-WC97010, CLEANSTART-2026-XM41413, CLEANSTART-2026-XM81599, DEBIAN-CVE-2026-69247, ECHO-896e-5bc2-1efe, GHSA-g6cj-pr64-35w5, MINI-2rhg-4f79-pjrp, MINI-3434-vv3v-gxfx, MINI-389w-m2vr-ff3p, MINI-4g9q-33qc-37fv, MINI-5jwf-pvpx-hmjp, MINI-5xp9-6rcp-3vgp, MINI-66jx-638c-x9p2, MINI-6f4r-x5fj-8cq5, MINI-6ppq-3fj9-hq6q, MINI-75x7-3f94-8cvf, MINI-7mp9-p9wv-5jjq, MINI-7v6w-3m6j-wm5f, MINI-7wph-hw5j-48hc, MINI-8389-v3vh-mj87, MINI-87rv-hx2x-grhq, MINI-88xq-rjwf-hm89, MINI-9hv9-c2r7-4x45, MINI-c768-439h-mvr2, MINI-fm45-68q6-x35m, MINI-fvgj-5qfm-6x86, MINI-ggxv-phgw-cr7c, MINI-h56q-c5c8-g22w, MINI-hv9p-g987-4fjp, MINI-j5fx-wv9f-7j3f, MINI-jj2f-pq5p-vr55, MINI-mcx7-95hx-2873, MINI-mh58-2fg4-mxh2, MINI-mr2j-v2pg-jfmc, MINI-p73q-5x9f-qqx8, MINI-phf4-56c8-6jg8, MINI-pq93-hvw8-6vcf, MINI-q765-q5mr-3rph, MINI-qgr6-9gcv-h8fh, MINI-qhvx-rq99-fcfp, MINI-x654-whpg-jp38, MINI-x9q4-m75f-hjf8, MINI-xcr4-4hqg-f7v2, PYSEC-2026-3552, ROOT-APP-PYPI-CVE-2026-69247, UBUNTU-CVE-2026-69247

## What is CVE-2026-69247?

CVE-2026-69247 is a high-severity vulnerability in pyca cryptography, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. From 44.0.0 until 50.0.0, pkcs7_decrypt_der, pkcs7_decrypt_pem, and pkcs7_decrypt_smime reported the outcome of decrypting a RecipientInfo's encryptedKey in several distinguishable ways, one of which disclosed the exact length recovered from the RSA operation. The same distinction was also observable by timing. An application that decrypts attacker-supplied EnvelopedData and reflects the outcome gives the attacker a Bleichenbacher oracle against the content-encryption key. Decryption ran as RSA PKCS#1 v1.5 decrypt of encryptedKey, build an AES cipher from the result, then AES-CBC decrypt and PKCS#7 unpad. Invalid RSA padding, a valid padding with a bad key length, a correct length with a wrong key, and the real key each failed or succeeded differently. Case 1 is reachable only where the linked library lacks implicit rejection: OpenSSL 3.0 and 3.1, LibreSSL, and BoringSSL. Exploitation requires a service that auto-decrypts untrusted EnvelopedData matching the victim certificate and answers adaptively at high volume, such as an S/MIME gateway or mail filter. This issue is fixed in 50.0.0.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information), CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2026-69247?

3 open source packages ship an affected version, including cryptography.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cryptography` | PyPI | From 44.0.0 | 50.0.0 |
| `cryptography` | PyPI | From 44.0.0 | 50.0.0 |
| `cryptography` | PyPI | From 44.0.0 | 50.0.0 |

## How do I fix CVE-2026-69247?

Upgrade cryptography to 50.0.0 or later.

## Is CVE-2026-69247 being exploited?

There is no known exploitation of CVE-2026-69247 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69247 and fix it if it is affected.

What it is: CVE-2026-69247 is a high-severity vulnerability in pyca cryptography, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-69247 in the wild and no public exploit code.

Affected packages and fixed versions:
- cryptography (PyPI): affected from 44.0.0; fixed in 50.0.0
- cryptography (PyPI): affected from 44.0.0; fixed in 50.0.0
- cryptography (PyPI): affected from 44.0.0; fixed in 50.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69247/ (Markdown: https://insights.sbomify.com/CVE-2026-69247/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69247
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69247
- OSV: https://osv.dev/vulnerability/CVE-2026-69247

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69247/
Summaries are generated and may contain mistakes; the official description above is the record.
