# CVE-2026-69248: python-cryptography verifier accepts wildcard DNS names allowing escape from permittedSubtrees

> Attackers can bypass certificate name constraints in python-cryptography by using wildcard DNS names, allowing acceptance of invalid certificate chains.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Aug 2026
- **Updated:** 2 Sep 2026
- **Also known as:** CLEANSTART-2026-FX71748, CLEANSTART-2026-PD33882, CLSA-2026-1790065768, DEBIAN-CVE-2026-69248, ECHO-1e23-77eb-13c2, GHSA-m2h6-j472-rp4c, MINI-264x-4xg6-q8wf, MINI-2hh7-8g9v-4cj7, MINI-2mw4-994j-66jx, MINI-3c76-ww3g-gg87, MINI-3fq7-r8pv-qq79, MINI-3jrx-7hrm-3j96, MINI-48v8-86q9-86v4, MINI-52x2-wcqw-vcqg, MINI-5pgr-f2jg-7846, MINI-664w-2294-35rh, MINI-6gv2-wwmp-6hch, MINI-6j2c-w7q3-g4q3, MINI-7f3w-c659-vphx, MINI-7gp2-76jf-8r86, MINI-7j4v-4hrj-g783, MINI-83pr-qr7r-g9hh, MINI-866v-m68f-vhf2, MINI-8j5p-69mx-456j, MINI-93pf-w6w9-m8rq, MINI-9jpw-j8j2-645r, MINI-g924-67fx-ch57, MINI-gjhq-hgfw-rp5g, MINI-gmr6-wm7j-3j34, MINI-gv5p-jmhv-m3v7, MINI-h224-rq62-8mwm, MINI-hmvp-cwjg-cvg5, MINI-hpvh-xj63-5x9g, MINI-jgh3-h6qp-mwm4, MINI-jxx8-2j4w-cwh5, MINI-p54f-p32v-qh9g, MINI-p5gq-525m-vpvm, MINI-qc57-6q5w-x3xq, MINI-rj88-r2hr-hff4, MINI-rp86-9f69-gchh, MINI-vpc2-2963-3f3j, MINI-vr4w-xmqv-3hrw, MINI-xhqh-xqrq-5ffc, PYSEC-2026-3554, ROOT-APP-PYPI-CVE-2026-69248, UBUNTU-CVE-2026-69248, openSUSE-SU-2026:12133-1

## What is CVE-2026-69248?

CVE-2026-69248 is a medium-severity vulnerability in pyca cryptography, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. In versions 45.0.0 through 48.0.0, if an intermediate constrained CA permits the DNS name foo.example.com, and the leaf certificate has a wildcard in its DNS SAN of *.example.com, python-cryptography's verifier accepts which allows escaping outside of the permitted names. The core issue is in DNSConstraint::matches, where a wildcard pattern was treated as matching a more-specific permitted constraint even though *.example.com can expand to sibling names such as bar.example.com outside foo.example.com. This allows acceptance of an invalid certificate chain. This issue is fixed in 49.0.0.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-69248?

3 open source packages ship an affected version, including cryptography.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cryptography` | PyPI | All versions | 49.0.0 |
| `cryptography` | PyPI | From 45.0.0 | 49.0.0 |
| `cryptography` | PyPI | From 45.0.0 | 49.0.0 |
| `matrix-synapse` | openSUSE:Tumbleweed | All versions | 1.163.0-1.1 |

## How do I fix CVE-2026-69248?

Upgrade cryptography to 49.0.0 or later.

## Is CVE-2026-69248 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69248 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69248 and fix it if it is affected.

What it is: CVE-2026-69248 is a medium-severity vulnerability in pyca cryptography, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69248 exists.

Affected packages and fixed versions:
- cryptography (PyPI): affected all versions; fixed in 49.0.0
- cryptography (PyPI): affected from 45.0.0; fixed in 49.0.0
- cryptography (PyPI): affected from 45.0.0; fixed in 49.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69248/ (Markdown: https://insights.sbomify.com/CVE-2026-69248/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69248
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69248
- OSV: https://osv.dev/vulnerability/CVE-2026-69248

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69248/
Summaries are generated and may contain mistakes; the official description above is the record.
