CVE-2026-69249 python-cryptography: Duplicate self-signed intermediates can cause exponential path-building
An attacker can cause resource exhaustion and denial of service by submitting certificate chains with duplicate self-signed intermediates to the Python cryptography library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-69249?
CVE-2026-69249 is a high-severity denial of service vulnerability in pyca cryptography, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
python-cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. In versions 42.0.0 through 48.0.0, when resolving invalid certificate chains that include duplicate copies of self-signed certificates, the processing recursively invokes the same candidate, leading to an exponential blowup. Although the limitation that the chain depth cannot exceed a specified maximum depth prevents unbounded recursion and guarantees termination, an attacker-controlled certificate chain can lead the processing to easily take more than 5s to reject in testing. This amplification could form the basis for a resource exhaustion denial of service attack. The core issue arises in the recursive nature of build_chain_inner, which does not de-duplicate against previously analyzed candidates. As the correctness of validation is not affected, the integrity of a system cannot be compromised through this vector, only its availability. This issue is fixed in 49.0.0.
Weakness: CWE-400
Which versions are affected by CVE-2026-69249?
3 open source packages ship an affected version, including cryptography.
| Package | Affected | Fixed in |
|---|---|---|
cryptography PyPI | All versions | 49.0.0 |
cryptography PyPI | From 42.0.0 | 49.0.0 |
cryptography PyPI | From 42.0.0 | 49.0.0 |
Linux distribution packages (10)
python3-cryptography AlmaLinux:10 | All versions | 43.0.0-4.el10_2.5 |
python-cryptography Red Hat:enterprise_linux:10.2 | All versions | 0:43.0.0-4.el10_2.5 |
python-cryptography-debugsource Red Hat:enterprise_linux:10.2 | All versions | 0:43.0.0-4.el10_2.5 |
python3-cryptography Red Hat:enterprise_linux:10.2 | All versions | 0:43.0.0-4.el10_2.5 |
python3-cryptography-debuginfo Red Hat:enterprise_linux:10.2 | All versions | 0:43.0.0-4.el10_2.5 |
python-cryptography Red Hat:enterprise_linux_eus:10.0 | All versions | 0:43.0.0-4.el10_0.1 |
python-cryptography-debugsource Red Hat:enterprise_linux_eus:10.0 | All versions | 0:43.0.0-4.el10_0.1 |
python3-cryptography Red Hat:enterprise_linux_eus:10.0 | All versions | 0:43.0.0-4.el10_0.1 |
python3-cryptography-debuginfo Red Hat:enterprise_linux_eus:10.0 | All versions | 0:43.0.0-4.el10_0.1 |
python-cryptography Rocky Linux:10 | All versions | 0:43.0.0-4.el10_2.5 |
How do I fix CVE-2026-69249?
Upgrade cryptography to 49.0.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-69249 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69249 exists.
Sources
Also known as ALSA-2026:71658, AZL-94584, CLEANSTART-2026-TX79542, CLEANSTART-2026-WP84262, CLSA-2026-1789377631, CLSA-2026-1789377744 and 51 more.