# CVE-2026-69253: Flowise Sandbox Escape to RCE

> An authenticated user can inject JavaScript via a crafted URL in custom tools to escape the sandbox and execute arbitrary code on the server.

- **Severity:** Critical 9.0 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** GHSA-wg86-r78f-74mp

## What is CVE-2026-69253?

CVE-2026-69253 is a critical code injection vulnerability in Flowiseai Flowise, published on 4 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flowise is a drag-and-drop user interface for building customized large language model (LLM) flows. Prior to version 3.1.3, several custom-tool components — AgentAsTool, ChatflowTool, and ExecuteFlow — ran code in the in-process  vm2  sandbox. To build that code, they inserted a user-controlled  baseURL  value straight into the JavaScript source, for example  const url = "${baseURL}/..."; . The only check on  baseURL  was  isValidURL , but a valid-looking URL can still contain characters that break out of a code string. An authenticated user could craft a  baseURL  that passed this check, closed the surrounding string, and injected their own JavaScript into the sandboxed script (code injection, CWE-94). The  vm2  sandbox runs in the same Node.js process as Flowise and exposes risky dependencies. As a result, the injected code could escape the sandbox and run arbitrary code on the Flowise server as the Flowise process user. Exploitation only requires an authenticated session. The issue is fixed in version 3.1.3, which passes the URL to the sandbox as data instead of inserting it into code and adds stricter URL validation.

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2026-69253?

4 open source packages ship an affected version, including flowise and flowise-components. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.1.3 |
| `flowise` | npm | All versions | 3.1.3 |
| `flowise-components` | npm | All versions | 3.1.3 |
| `flowise-components` | npm | All versions | 3.1.3 |

Products: Flowiseai Flowise.

## How do I fix CVE-2026-69253?

Upgrade flowise to 3.1.3 or later.

## Is CVE-2026-69253 being exploited?

There is no known exploitation of CVE-2026-69253 in the wild and no public exploit code.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69253 and fix it if it is affected.

What it is: CVE-2026-69253 is a critical code injection vulnerability in Flowiseai Flowise, published on 4 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-69253 in the wild and no public exploit code.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.1.3
- flowise (npm): affected all versions; fixed in 3.1.3
- flowise-components (npm): affected all versions; fixed in 3.1.3
- flowise-components (npm): affected all versions; fixed in 3.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69253/ (Markdown: https://insights.sbomify.com/CVE-2026-69253/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69253
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69253
- OSV: https://osv.dev/vulnerability/CVE-2026-69253

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69253/
Summaries are generated and may contain mistakes; the official description above is the record.
