{"answers":{"affected":"2 open source packages ship an affected version, including flowise. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69257 exists.","fix":"Upgrade flowise to 3.1.3 or later.","what":"CVE-2026-69257 is a high-severity server-side request forgery vulnerability in Flowiseai Flowise, published on 4 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-69257 and fix it if it is affected.\n\nWhat it is: CVE-2026-69257 is a high-severity server-side request forgery vulnerability in Flowiseai Flowise, published on 4 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69257 exists.\n\nAffected packages and fixed versions:\n- flowise (npm): affected all versions; fixed in 3.1.3\n- flowise (npm): affected all versions; fixed in 3.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-69257/ (Markdown: https://insights.sbomify.com/CVE-2026-69257/index.md)","id":"CVE-2026-69257","markdown":"https://insights.sbomify.com/CVE-2026-69257/index.md","name":"CVE-2026-69257","record":{"aliases":["GHSA-c6xh-wv4j-ppv5"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM flow builder","requires_auth":"low_privilege","summary":"Attackers can bypass SSRF protections in Flowise to access internal services or cloud metadata by exploiting IPv4-mapped IPv6 address normalization flaws.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"flowise","vendor":"flowiseai"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"},{"id":"CWE-1389","name":"Incorrect Parsing of Numbers with Different Radices"}],"description":"Flowise is a drag \u0026 drop user interface to build a customized large language model flow. Prior to 3.1.3, Flowise's HTTP security module httpSecurity.ts did not normalize IPv4-mapped IPv6 addresses such as ::ffff:127.0.0.1 and ::ffff:169.254.169.254 before checking them against the deny list. Because ipaddr.js reports these addresses as ipv6 while IPv4 CIDR deny-list entries are ipv4, isDeniedIP() skipped the IPv4 CIDR checks. An attacker who controls DNS resolution for a hostname used by the HTTP Node, API Chain, Document Loader, MCP tool, or other paths using secureAxiosRequest(), secureFetch(), or checkDenyList() could return a AAAA record for an IPv4-mapped target and cause requests to reach localhost, internal services, or cloud metadata endpoints. This issue is fixed in version 3.1.3.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Flowise: SSRF Protection Bypass via IPv4-Mapped IPv6 Addresses","id":"CVE-2026-69257","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"flowiseai:flowise","products":["flowiseai:flowise"],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"Flowise: Unauthenticated Property Injection into Flow Execution Context via Ungated `overrideConfig` Spread in Prediction API","id":"CVE-2026-69258"},"packages":[{"ecosystem":"npm","fixed":["3.1.3"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":null,"source":"GHSA-c6xh-wv4j-ppv5"},{"ecosystem":"npm","fixed":["3.1.3"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":"pkg:npm/flowise","source":"GHSA-c6xh-wv4j-ppv5"}],"prev":{"headline":"Flowise: Remote Code Execution Vulnerability in CSVAgent","id":"CVE-2026-69256"},"products":["Flowise"],"published":"2026-08-04","related":[{"cvss_score":10,"headline":"Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API","id":"CVE-2025-71338","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":10,"headline":"Flowise: Authenticated RCE Via MCP Adapters","id":"CVE-2026-40933","kev_date_added":null,"published":"2026-04-21"},{"cvss_score":10,"headline":"Flowise is vulnerable to arbitrary file read, arbitrary file write","id":"CVE-2025-61913","kev_date_added":null,"published":"2025-10-08"},{"cvss_score":10,"headline":"Flowise has Remote Code Execution vulnerability","id":"CVE-2025-59528","kev_date_added":null,"published":"2025-09-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2026-52098","kev_date_added":null,"published":"2026-09-10"},{"cvss_score":9.8,"headline":"Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover","id":"CVE-2025-58434","kev_date_added":null,"published":"2025-09-12"},{"cvss_score":9.8,"headline":"Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers","id":"CVE-2025-8943","kev_date_added":null,"published":"2025-08-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-04","vendors":["FlowiseAI"]},"summary":"Attackers can bypass SSRF protections in Flowise to access internal services or cloud metadata by exploiting IPv4-mapped IPv6 address normalization flaws.","url":"https://insights.sbomify.com/CVE-2026-69257/"}