# CVE-2026-69262: Flowise: `DELETE /api/v1/chatflows/:id` does not validate resource type, allowing `agentflows:delete` and `chatflows:delete` to delete each other’s flow type

> Attackers with one delete permission can delete the other flow type due to missing resource type validation in the delete API.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** GHSA-p5w8-m249-4r4v

## What is CVE-2026-69262?

CVE-2026-69262 is a high-severity missing authorization vulnerability in Flowiseai Flowise, published on 4 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, `DELETE /api/v1/chatflows/:id` authorized requests with checkAnyPermission('chatflows:delete,agentflows:delete'), so possession of either permission was sufficient to reach the delete path. The delete logic then resolved the target record only by id and workspaceId and did not validate the target resource type, allowing a caller with only agentflows:delete to delete a CHATFLOW and a caller with only chatflows:delete to delete an AGENTFLOW in the same workspace. This issue is fixed in version 3.1.3.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-69262?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.1.3 |
| `flowise` | npm | All versions | 3.1.3 |

Products: Flowiseai Flowise.

## How do I fix CVE-2026-69262?

Upgrade flowise to 3.1.3 or later.

## Is CVE-2026-69262 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69262 exists.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69262 and fix it if it is affected.

What it is: CVE-2026-69262 is a high-severity missing authorization vulnerability in Flowiseai Flowise, published on 4 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69262 exists.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.1.3
- flowise (npm): affected all versions; fixed in 3.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69262/ (Markdown: https://insights.sbomify.com/CVE-2026-69262/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69262
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69262
- OSV: https://osv.dev/vulnerability/CVE-2026-69262

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69262/
Summaries are generated and may contain mistakes; the official description above is the record.
