# CVE-2026-6951: simple-git is vulnerable to Remote Code Execution

> Attackers can achieve remote code execution in simple-git by bypassing previous fixes using the --config option to enable dangerous git protocols.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2026
- **Updated:** 14 Sep 2026
- **Also known as:** CLEANSTART-2026-JS30109, CLEANSTART-2026-RJ14281, CLEANSTART-2026-XH29578, GHSA-hffm-xvc3-vprc, MINI-w8wf-48cc-3wff, ROOT-APP-NPM-CVE-2026-6951

## What is CVE-2026-6951?

CVE-2026-6951 is a critical command injection vulnerability in org.webjars.npm:simple-git, published on 25 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package simple-git before 3.36.0 are vulnerable to Remote Code Execution (RCE) due to an incomplete fix for [CVE-2022-25912](https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-3112221) that blocks the -c option but not the equivalent --config form. If untrusted input can reach the options argument passed to simple-git, an attacker may still achieve remote code execution by enabling protocol.ext.allow=always and using an ext:: clone source.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-6951?

2 open source packages ship an affected version, including simple-git. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simple-git` | npm | All versions | 3.36.0 |
| `simple-git` | npm | All versions | 3.36.0 |

Products: Simple-Git Project Simple-Git.

## How do I fix CVE-2026-6951?

Upgrade simple-git to 3.36.0 or later.

## Is CVE-2026-6951 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-6951 exists.

Public exploit code:

- simple-git RCE (github_poc): https://github.com/EQSTLab/CVE-2026-6951

## Other vulnerabilities in org.webjars.npm:simple-git

- [CVE-2026-28292](https://insights.sbomify.com/CVE-2026-28292/): simple-git has blockUnsafeOperationsPlugin bypass via case-insensitive protocol.allow config key that enables RCE (critical 9.8)
- [CVE-2026-102828](https://insights.sbomify.com/CVE-2026-102828/): simple-git unsafe-operation guard does not block trailer command configuration (critical 9.2)
- [CVE-2026-102826](https://insights.sbomify.com/CVE-2026-102826/): simple-git allows command execution through unblocked Git configuration includes (high 8.1)
- [CVE-2026-102827](https://insights.sbomify.com/CVE-2026-102827/): simple-git: unsafe-operations plugin bypass via git long-option abbreviation (--receive-p/--exe) -> command execution (residual of CVE-2026-28291) (high 8.1)
- [CVE-2026-28291](https://insights.sbomify.com/CVE-2026-28291/): simple-git has Command Execution via Option-Parsing Bypass (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6951 and fix it if it is affected.

What it is: CVE-2026-6951 is a critical command injection vulnerability in org.webjars.npm:simple-git, published on 25 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-6951 exists.

Affected packages and fixed versions:
- simple-git (npm): affected all versions; fixed in 3.36.0
- simple-git (npm): affected all versions; fixed in 3.36.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6951/ (Markdown: https://insights.sbomify.com/CVE-2026-6951/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6951
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6951
- OSV: https://osv.dev/vulnerability/CVE-2026-6951

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6951/
Summaries are generated and may contain mistakes; the official description above is the record.
