# CVE-2026-6959: Nomad vulnerable to arbitrary file read/write on client host through symlink attack

> Attackers can read or write arbitrary files on the client host via symlink attacks, requiring an upgrade to secure the Nomad process.

- **Severity:** Medium 6.0 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2026
- **Updated:** 12 May 2026
- **Also known as:** GHSA-3934-423w-4jq3, GO-2026-5076, UBUNTU-CVE-2026-6959

## What is CVE-2026-6959?

CVE-2026-6959 is a medium-severity path traversal vulnerability in HashiCorp Nomad, published on 12 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

HashiCorp Nomad and Nomad Enterprise prior to 2.0.1 are vulnerable to arbitrary file read and write on the client host as the Nomad process user through a symlink attack. This vulnerability (CVE-2026-6959) is fixed in Nomad 2.0.1, 1.11.5 and 1.10.11.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2026-6959?

3 open source packages ship an affected version, including github.com/hashicorp/nomad.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/nomad` | Go | All versions | 1.11.0-rc.1.0.20260512123500-2a09fd62c238 |
| `github.com/hashicorp/nomad` | Go | All versions | 1.11.0-rc.1.0.20260512123500-2a09fd62c238 |
| `github.com/hashicorp/nomad` | Go | All versions | 1.11.0-rc.1.0.20260512123500-2a09fd62c238 |

## How do I fix CVE-2026-6959?

Upgrade github.com/hashicorp/nomad to 1.11.0-rc.1.0.20260512123500-2a09fd62c238 or later.

## Is CVE-2026-6959 being exploited?

There is no known exploitation of CVE-2026-6959 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6959 and fix it if it is affected.

What it is: CVE-2026-6959 is a medium-severity path traversal vulnerability in HashiCorp Nomad, published on 12 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6959 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/nomad (Go): affected all versions; fixed in 1.11.0-rc.1.0.20260512123500-2a09fd62c238
- github.com/hashicorp/nomad (Go): affected all versions; fixed in 1.11.0-rc.1.0.20260512123500-2a09fd62c238
- github.com/hashicorp/nomad (Go): affected all versions; fixed in 1.11.0-rc.1.0.20260512123500-2a09fd62c238

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6959/ (Markdown: https://insights.sbomify.com/CVE-2026-6959/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6959
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6959
- OSV: https://osv.dev/vulnerability/CVE-2026-6959

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6959/
Summaries are generated and may contain mistakes; the official description above is the record.
