CVE-2026-6961 CVE-2026-6961: Path traversal via unsanitized FileInfo.Name in Mattermost federation sync
An attacker controlling a federated server can write files to arbitrary locations on the target Mattermost server via path traversal in filenames.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-6961?
CVE-2026-6961 is a high-severity path traversal vulnerability in Mattermost Mattermost Server, published on 12 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 11.6.x <= 11.6.1, 11.5.x <= 11.5.4, 10.11.x <= 10.11.15, 10.11.x <= 10.11.16 Mattermost fails to sanitize FileInfo.Name received from federated peers during shared channel file sync, which allows an attacker who controls a federated server to write files to arbitrary locations within the target server's filestore via path traversal sequences in the filename field.. Mattermost Advisory ID: MMSA-2026-00661
Weakness: CWE-22
Which versions are affected by CVE-2026-6961?
12 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.17 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.17 |
github.com/mattermost/mattermost-server Go | From 10.11.0+incompatible | 10.11.17+incompatible, 11.5.5+incompatible, 11.6.1+incompatible |
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.5 |
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.5 |
github.com/mattermost/mattermost-server Go | From 11.6.0 | 11.6.1 |
6 more packages
github.com/mattermost/mattermost-server Go | From 11.6.0 | 11.6.1 |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | From 8.0.0-20250731163400-5b955468ea1e | 8.0.0-20260423180926-c021eeaff8f0 |
github.com/mattermost/mattermost/server/v8 Go | From 8.0.0-20250731163400-5b955468ea1e | 8.0.0-20260423180926-c021eeaff8f0 |
github.com/mattermost/mattermost/server/v8 Go | From 8.0.0-20250731163400-5b955468ea1e | 8.0.0-20260423180926-c021eeaff8f0 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-6961?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.17, 10.11.17+incompatible, 11.5.5+incompatible or 11.6.1+incompatible.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2026-6961 being exploited?
There is no known exploitation of CVE-2026-6961 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-8qq9-cqj8-82w4, GO-2026-6281.