# CVE-2026-6961: CVE-2026-6961: Path traversal via unsanitized FileInfo.Name in Mattermost federation sync

> An attacker controlling a federated server can write files to arbitrary locations on the target Mattermost server via path traversal in filenames.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 16 Jun 2026
- **Also known as:** GHSA-8qq9-cqj8-82w4, GO-2026-6281

## What is CVE-2026-6961?

CVE-2026-6961 is a high-severity path traversal vulnerability in Mattermost Mattermost Server, published on 12 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Mattermost versions 11.6.x <= 11.6.1, 11.5.x <= 11.5.4, 10.11.x <= 10.11.15, 10.11.x <= 10.11.16 Mattermost fails to sanitize FileInfo.Name received from federated peers during shared channel file sync, which allows an attacker who controls a federated server to write files to arbitrary locations within the target server's filestore via path traversal sequences in the filename field.. Mattermost Advisory ID: MMSA-2026-00661

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-6961?

12 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.17 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.17 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0+incompatible | 10.11.17+incompatible, 11.5.5+incompatible, 11.6.1+incompatible |
| `github.com/mattermost/mattermost-server` | Go | From 11.5.0 | 11.5.5 |
| `github.com/mattermost/mattermost-server` | Go | From 11.5.0 | 11.5.5 |
| `github.com/mattermost/mattermost-server` | Go | From 11.6.0 | 11.6.1 |
| `github.com/mattermost/mattermost-server` | Go | From 11.6.0 | 11.6.1 |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | From 8.0.0-20250731163400-5b955468ea1e | 8.0.0-20260423180926-c021eeaff8f0 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 8.0.0-20250731163400-5b955468ea1e | 8.0.0-20260423180926-c021eeaff8f0 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 8.0.0-20250731163400-5b955468ea1e | 8.0.0-20260423180926-c021eeaff8f0 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2026-6961?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.17, 10.11.17+incompatible, 11.5.5+incompatible or 11.6.1+incompatible.

## Is CVE-2026-6961 being exploited?

There is no known exploitation of CVE-2026-6961 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6961 and fix it if it is affected.

What it is: CVE-2026-6961 is a high-severity path traversal vulnerability in Mattermost Mattermost Server, published on 12 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6961 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.17
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.17
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0+incompatible; fixed in 10.11.17+incompatible, 11.5.5+incompatible, 11.6.1+incompatible
- github.com/mattermost/mattermost-server (Go): affected from 11.5.0; fixed in 11.5.5
- github.com/mattermost/mattermost-server (Go): affected from 11.5.0; fixed in 11.5.5
- github.com/mattermost/mattermost-server (Go): affected from 11.6.0; fixed in 11.6.1
- github.com/mattermost/mattermost-server (Go): affected from 11.6.0; fixed in 11.6.1
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected from 8.0.0-20250731163400-5b955468ea1e; fixed in 8.0.0-20260423180926-c021eeaff8f0
- github.com/mattermost/mattermost/server/v8 (Go): affected from 8.0.0-20250731163400-5b955468ea1e; fixed in 8.0.0-20260423180926-c021eeaff8f0
- github.com/mattermost/mattermost/server/v8 (Go): affected from 8.0.0-20250731163400-5b955468ea1e; fixed in 8.0.0-20260423180926-c021eeaff8f0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6961/ (Markdown: https://insights.sbomify.com/CVE-2026-6961/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6961
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6961
- OSV: https://osv.dev/vulnerability/CVE-2026-6961

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6961/
Summaries are generated and may contain mistakes; the official description above is the record.
