{"answers":{"affected":"3 open source packages ship an affected version, including github.com/canonical/authd.","exploited":"There is no known exploitation of CVE-2026-6970 in the wild and no public exploit code.","fix":"Upgrade github.com/canonical/authd to 0.6.4 or later.","what":"CVE-2026-6970 is a high-severity vulnerability in Canonical authd, published on 27 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-6970 and fix it if it is affected.\n\nWhat it is: CVE-2026-6970 is a high-severity vulnerability in Canonical authd, published on 27 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-6970 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/canonical/authd (Go): affected from 0.6.0; fixed in 0.6.4\n- github.com/canonical/authd (Go): affected from 0.6.0; fixed in 0.6.4\n- github.com/canonical/authd (Go): affected from 0.6.0; fixed in 0.6.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6970/ (Markdown: https://insights.sbomify.com/CVE-2026-6970/index.md)","id":"CVE-2026-6970","markdown":"https://insights.sbomify.com/CVE-2026-6970/index.md","name":"CVE-2026-6970","record":{"aliases":["GHSA-fg3j-5w9g-hmg7","GO-2026-5361","UBUNTU-CVE-2026-6970","USN-8212-1"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["privilege_escalation","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ubuntu authd","requires_auth":"low_privilege","summary":"A logic error in authd allows local privilege escalation and denial of service by incorrectly resetting user group IDs during login.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"canonical","cpe":[],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-842","name":"Placement of User into Incorrect Group"}],"description":"authd prior to version 0.6.4 contains a logic error in primary group ID assignment that can lead to local privilege escalation. When a user's primary group ID (GID) differs from their UID, either because the account was created with authd prior to version 0.5.4 or because the primary group was manually changed via the `authctl group set-gid` command, and the user's identity provider record is updated, authd incorrectly resets the user's primary group ID to their UID upon next login. This causes newly created files and directories to be owned by the wrong group, causing denial of service issues, and potentially granting unintended access to other local users and allowing local privilege escalation.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"authd Denial of Service and Local Privilege Escalation","id":"CVE-2026-6970","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"SKT Skill Bar \u003c= 2.6 - Authenticated (Contributor+) Stored Cross-Site Scripting","id":"CVE-2026-6972"},"packages":[{"ecosystem":"Go","fixed":["0.6.4"],"introduced":["0.6.0"],"last_affected":[],"package":"github.com/canonical/authd","purl":null,"source":"GHSA-fg3j-5w9g-hmg7"},{"ecosystem":"Go","fixed":["0.6.4"],"introduced":["0.6.0"],"last_affected":[],"package":"github.com/canonical/authd","purl":"pkg:golang/github.com/canonical/authd","source":"GHSA-fg3j-5w9g-hmg7"},{"ecosystem":"Go","fixed":["0.6.4"],"introduced":["0.6.0"],"last_affected":[],"package":"github.com/canonical/authd","purl":"pkg:golang/github.com/canonical/authd","source":"GO-2026-5361"}],"prev":{"headline":"Multiple Path Traversal Variants in awslabs/tough","id":"CVE-2026-6968"},"products":["authd"],"published":"2026-04-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-27","vendors":["Canonical"]},"summary":"A logic error in authd allows local privilege escalation and denial of service by incorrectly resetting user group IDs during login.","url":"https://insights.sbomify.com/CVE-2026-6970/"}