# CVE-2026-6970: authd Denial of Service and Local Privilege Escalation

> A logic error in authd allows local privilege escalation and denial of service by incorrectly resetting user group IDs during login.

- **Severity:** High 7.3 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Apr 2026
- **Updated:** 27 Apr 2026
- **Also known as:** GHSA-fg3j-5w9g-hmg7, GO-2026-5361, UBUNTU-CVE-2026-6970, USN-8212-1

## What is CVE-2026-6970?

CVE-2026-6970 is a high-severity vulnerability in Canonical authd, published on 27 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

authd prior to version 0.6.4 contains a logic error in primary group ID assignment that can lead to local privilege escalation. When a user's primary group ID (GID) differs from their UID, either because the account was created with authd prior to version 0.5.4 or because the primary group was manually changed via the `authctl group set-gid` command, and the user's identity provider record is updated, authd incorrectly resets the user's primary group ID to their UID upon next login. This causes newly created files and directories to be owned by the wrong group, causing denial of service issues, and potentially granting unintended access to other local users and allowing local privilege escalation.

Weakness: CWE-842 (Placement of User into Incorrect Group)

## Which versions are affected by CVE-2026-6970?

3 open source packages ship an affected version, including github.com/canonical/authd.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/canonical/authd` | Go | From 0.6.0 | 0.6.4 |
| `github.com/canonical/authd` | Go | From 0.6.0 | 0.6.4 |
| `github.com/canonical/authd` | Go | From 0.6.0 | 0.6.4 |

## How do I fix CVE-2026-6970?

Upgrade github.com/canonical/authd to 0.6.4 or later.

## Is CVE-2026-6970 being exploited?

There is no known exploitation of CVE-2026-6970 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6970 and fix it if it is affected.

What it is: CVE-2026-6970 is a high-severity vulnerability in Canonical authd, published on 27 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6970 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/canonical/authd (Go): affected from 0.6.0; fixed in 0.6.4
- github.com/canonical/authd (Go): affected from 0.6.0; fixed in 0.6.4
- github.com/canonical/authd (Go): affected from 0.6.0; fixed in 0.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6970/ (Markdown: https://insights.sbomify.com/CVE-2026-6970/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6970
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6970
- OSV: https://osv.dev/vulnerability/CVE-2026-6970

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6970/
Summaries are generated and may contain mistakes; the official description above is the record.
