{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7014 exists.","fix":"No fix has been published for CVE-2026-7014 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-7014 is a medium-severity cross-site scripting vulnerability in MaxSite CMS, published on 26 Apr 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-7014 and fix it if it is affected.\n\nWhat it is: CVE-2026-7014 is a medium-severity cross-site scripting vulnerability in MaxSite CMS, published on 26 Apr 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7014 exists.\n\nAffected product: MaxSite CMS. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-7014/ (Markdown: https://insights.sbomify.com/CVE-2026-7014/index.md)","id":"CVE-2026-7014","markdown":"https://insights.sbomify.com/CVE-2026-7014/index.md","name":"CVE-2026-7014","record":{"aliases":["GHSA-gfm4-7pv3-76ph"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MaxSite CMS plugin","requires_auth":"high_privilege","summary":"A cross-site scripting vulnerability in the MaxSite CMS down_count plugin allows remote attackers to inject malicious scripts via the f_file or f_prefix arguments.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A flaw has been found in MaxSite CMS up to 109.3. This vulnerability affects unknown code of the component down_count Plugin. This manipulation of the argument f_file/f_prefix causes cross site scripting. The attack may be initiated remotely. The exploit has been published and may be used. Upgrading to version 109.4 is able to resolve this issue. Patch name: 8a3946bd0a54bfb72a4d57179fcd253f2c550cd7. The affected component should be upgraded. The vendor was informed early about this issue. They classify it as a \"Self-XSS\". They deployed a countermeasure: \"Nevertheless, we consider this a violation of secure coding standards. The lack of filtering via `htmlspecialchars()` has already been fixed in the latest patch to prevent incorrect data display.\"","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"MaxSite CMS down_count Plugin cross site scripting","id":"CVE-2026-7014","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":7,"next":{"headline":"MaxSite CMS Guestbook Plugin cross site scripting","id":"CVE-2026-7015"},"packages":[],"prev":{"headline":"MaxSite CMS mail_send Plugin cross site scripting","id":"CVE-2026-7013"},"products":["CMS"],"published":"2026-04-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-27","vendors":["MaxSite"]},"summary":"A cross-site scripting vulnerability in the MaxSite CMS down_count plugin allows remote attackers to inject malicious scripts via the f_file or f_prefix arguments.","url":"https://insights.sbomify.com/CVE-2026-7014/"}