# CVE-2026-7015: MaxSite CMS Guestbook Plugin cross site scripting

> Remote attackers can inject malicious scripts via Guestbook plugin inputs, potentially executing code in victim browsers.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 26 Apr 2026
- **Updated:** 27 Apr 2026
- **Also known as:** GHSA-28c9-8fx6-5h79

## What is CVE-2026-7015?

CVE-2026-7015 is a medium-severity cross-site scripting vulnerability in MaxSite CMS, published on 26 Apr 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A vulnerability has been found in MaxSite CMS up to 109.3. This issue affects some unknown processing of the component Guestbook Plugin. Such manipulation of the argument f_text/f_slug/f_limit/f_email leads to cross site scripting. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 109.4 is capable of addressing this issue. The name of the patch is 8a3946bd0a54bfb72a4d57179fcd253f2c550cd7. It is suggested to upgrade the affected component. The vendor was informed early about this issue. They classify it as a "Self-XSS". They deployed a countermeasure: "Nevertheless, we consider this a violation of secure coding standards. The lack of filtering via `htmlspecialchars()` has already been fixed in the latest patch to prevent incorrect data display."

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-7015?


## How do I fix CVE-2026-7015?

No fix has been published for CVE-2026-7015 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-7015 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7015 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7015 and fix it if it is affected.

What it is: CVE-2026-7015 is a medium-severity cross-site scripting vulnerability in MaxSite CMS, published on 26 Apr 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7015 exists.

Affected product: MaxSite CMS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7015/ (Markdown: https://insights.sbomify.com/CVE-2026-7015/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7015
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7015
- OSV: https://osv.dev/vulnerability/CVE-2026-7015

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7015/
Summaries are generated and may contain mistakes; the official description above is the record.
