# CVE-2026-70410: Apache Calcite Avatica: Unrestricted class initialization when instantiating plugins

> Attackers can trigger arbitrary class initialization via unsafe reflection in Apache Calcite Avatica, potentially executing static initializer blocks.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 22 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-rqpp-92mg-pcvc

## What is CVE-2026-70410?

CVE-2026-70410 is a high-severity code injection vulnerability in Apache Calcite Avatica, published on 22 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite Avatica. Plugin instantiation (via AvaticaUtils#instantiatePlugin and other methods) initializes arbitrary classes via unrestricted calls to Class.forName(String) which by default triggers initialization. This may lead to the execution of static initializer blocks in arbitrary classes present in the classpath. The instantiation APIs should initialize and instantiate only classes implementing the specified plugin interface passed as input in conjunction with the desired classname. At the moment of writing, there are no well-known or widely used classes with dangerous static initializer blocks so the severity is low.

This issue affects Apache Calcite Avatica: before 1.29.0.

Users are recommended to upgrade to version 1.29.0, which fixes the issue.

Weakness: CWE-470 (Use of Externally-Controlled Input to Select Classes or Code)

## Which versions are affected by CVE-2026-70410?


## How do I fix CVE-2026-70410?

No fix has been published for CVE-2026-70410 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-70410 being exploited?

There is no known exploitation of CVE-2026-70410 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-70410 and fix it if it is affected.

What it is: CVE-2026-70410 is a high-severity code injection vulnerability in Apache Calcite Avatica, published on 22 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-70410 in the wild and no public exploit code.

Affected product: Apache Calcite Avatica. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-70410/ (Markdown: https://insights.sbomify.com/CVE-2026-70410/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-70410
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-70410
- OSV: https://osv.dev/vulnerability/CVE-2026-70410

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-70410/
Summaries are generated and may contain mistakes; the official description above is the record.
